Skip to content

← Actionable
Medium, CVSS 5.3amended

Next.js: null origin can bypass Server Actions CSRF checks

CVE-2026-27978GHSA-mq59-m269-xvcx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (next 16.1.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm next

    Affected
    >= 16.0.1, < 16.1.7
    Fixed in
    16.1.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-27978: 0.21% estimated exploitation activity in the next 30 days; percentile 11.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary origin: null was treated as a "missing" origin during Server Action CSRF validation. As a result, requests from opaque contexts (such as sandboxed iframes) could bypass origin verification instead of being validated as cross-origin requests. Impact An attacker could induce a victim browser to submit Server Actions from a sandboxed context, potentially executing state-changing actions with victim credentials (CSRF). Patches Fixed by treating 'null' as an explicit origin value and enforcing host/origin checks unless 'null' is explicitly allowlisted in experimental.serverActions.allowedOrigins. Workarounds If upgrade is not immediately possible: - Add CSRF tokens for sensitive Server Actions. - Prefer SameSite=Strict on sensitive auth cookies. - Do not allow 'null' in serverActions.allowedOrigins unless intentionally required and additionally protected.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-mq59-m269-xvcx

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-mq59-m269-xvcx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-27978

Advisory: Next.js: null origin can bypass Server Actions CSRF checks
IDs: CVE-2026-27978, GHSA-mq59-m269-xvcx
Record: https://patchnext.com/advisories/cve-2026-27978 (revision 3, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: next 16.1.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm next: affected >= 16.0.1, < 16.1.7; fixed in 16.1.7

## Suggested inspection (read-only)
- `npm ls next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on next.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mq59-m269-xvcx (OSV record GHSA-mq59-m269-xvcx lists affected ranges: npm next >=16.0.1 <16.1.7 (fixed))
- Verified: https://github.com/advisories/GHSA-mq59-m269-xvcx (GitHub-reviewed advisory GHSA-mq59-m269-xvcx lists affected ranges: npm next >=16.0.1 <16.1.7)

Commands are suggestions: review each one before running it.

Loading voting…