Skip to content

← Actionable
Low, CVSS 2.3amended

Next.js: null origin can bypass dev HMR websocket CSRF checks

CVE-2026-27977GHSA-jcc7-9wpm-mj36

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (next 16.1.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm next

    Affected
    >= 16.0.1, < 16.1.7
    Fixed in
    16.1.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-27977: 0.18% estimated exploitation activity in the next 30 days; percentile 7.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary In next dev, cross-site protections for internal development endpoints could treat Origin: null as a bypass case even when allowedDevOrigins is configured. This could allow privacy-sensitive or opaque browser contexts, such as sandboxed documents, to access privileged internal dev-server functionality unexpectedly. Impact If a developer visits attacker-controlled content while running an affected next dev server with allowedDevOrigins configured, attacker-controlled browser code may be able to connect to internal development endpoints and interact with sensitive dev-server functionality that should have remained blocked. This issue affects development mode only. It does not affect next start, and it does not expose internal debugging functionality to the network by default. Patches Fixed by validating Origin: null through the same cross-site origin-allowance checks used for other origins on internal development endpoints. Workarounds If upgrade is not immediately possible: -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-jcc7-9wpm-mj36

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-jcc7-9wpm-mj36

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-27977

Advisory: Next.js: null origin can bypass dev HMR websocket CSRF checks
IDs: CVE-2026-27977, GHSA-jcc7-9wpm-mj36
Record: https://patchnext.com/advisories/cve-2026-27977 (revision 3, source checked 26 Oct 2026, 12:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: next 16.1.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm next: affected >= 16.0.1, < 16.1.7; fixed in 16.1.7

## Suggested inspection (read-only)
- `npm ls next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on next.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jcc7-9wpm-mj36 (OSV record GHSA-jcc7-9wpm-mj36 lists affected ranges: npm next >=16.0.1 <16.1.7 (fixed))
- Verified: https://github.com/advisories/GHSA-jcc7-9wpm-mj36 (GitHub-reviewed advisory GHSA-jcc7-9wpm-mj36 lists affected ranges: npm next >=16.0.1 <16.1.7)

Commands are suggestions: review each one before running it.

Loading voting…