Skip to content

← Actionable
High, CVSS 8.1amended

Ajenti has potential Remote Code Execution

CVE-2026-27975GHSA-vcw3-r3fx-j444

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (aj 2.2.13), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI aj

    Affected
    < 2.2.13
    Fixed in
    2.2.13

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2026-27975: 0.59% estimated exploitation activity in the next 30 days; percentile 48.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An unauthenticated user could gain access to a server to execute arbitrary code on this server.

Patches This is fixed in the version 2.2.13. Users should upgrade to this version as soon as possible.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-vcw3-r3fx-j444

  2. Revision 1 · created ·

    Published from ghsa record GHSA-vcw3-r3fx-j444

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-27975

Advisory: Ajenti has potential Remote Code Execution
IDs: CVE-2026-27975, GHSA-vcw3-r3fx-j444
Record: https://patchnext.com/advisories/cve-2026-27975 (revision 2, source checked 28 Oct 2026, 06:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: aj 2.2.13. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI aj: affected < 2.2.13; fixed in 2.2.13

## Suggested inspection (read-only)
- `python -m pip show aj`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on aj.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vcw3-r3fx-j444 (OSV record GHSA-vcw3-r3fx-j444 lists affected ranges: PyPI aj >=0 <2.2.13 (fixed))
- Verified: https://github.com/advisories/GHSA-vcw3-r3fx-j444 (GitHub-reviewed advisory GHSA-vcw3-r3fx-j444 lists affected ranges: PyPI aj >=0 <2.2.13)

Commands are suggestions: review each one before running it.

Loading voting…