Angular i18n vulnerable to Cross-Site Scripting
CVE-2026-27970GHSA-prjf-86w9-mfqv
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @angular/core
- Affected
- >= 21.2.0-next.0, <= 21.2.0-rc.0>= 21.0.0-next.0, <= 21.1.5>= 20.0.0-next.0, <= 20.3.16>= 19.0.0-next.0, <= 19.2.18<= 18.2.14
- Fixed in
- 20.3.17, 19.2.19, 21.1.6, 21.2.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-prjf-86w9-mfqv lists affected ranges: npm @angular/core >=21.2.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 <=18.2.14
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-prjf-86w9-mfqv lists affected ranges: npm @angular/core >=21.2.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 <=18.2.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.0 · CVSS:4.0/AV:L/AC:L/AT:N/PR:H/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-27970: 0.55% estimated exploitation activity in the next 30 days; percentile 45.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A Cross-site Scripting (XSS) vulnerability has been identified in the Angular internationalization (i18n) pipeline. In ICU messages (International Components for Unicode), HTML from translated content was not properly sanitized and could execute arbitrary JavaScript. Angular i18n typically involves three steps, extracting all messages from an application in the source language, sending the messages to be translated, and then merging their translations back into the final source code. Translations are frequently handled by contracts with specific partner companies, and involve sending the source messages to a separate contractor before receiving final translations for display to the end user. If the returned translations have malicious content, it could be rendered into the application and execute arbitrary JavaScript. Impact When successfully exploited, this vulnerability allows for execution of attacker controlled JavaScript in the application origin. Depending on the nature of the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-prjf-86w9-mfqv
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-prjf-86w9-mfqv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-27970 Advisory: Angular i18n vulnerable to Cross-Site Scripting IDs: CVE-2026-27970, GHSA-prjf-86w9-mfqv Record: https://patchnext.com/advisories/cve-2026-27970 (revision 3, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: @angular/core 21.2.0, 21.1.6, 20.3.17, 19.2.19. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @angular/core: affected >= 21.2.0-next.0, <= 21.2.0-rc.0; >= 21.0.0-next.0, <= 21.1.5; >= 20.0.0-next.0, <= 20.3.16; >= 19.0.0-next.0, <= 19.2.18; <= 18.2.14; fixed in 20.3.17, 19.2.19, 21.1.6, 21.2.0 ## Suggested inspection (read-only) - `npm ls @angular/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @angular/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-prjf-86w9-mfqv (OSV record GHSA-prjf-86w9-mfqv lists affected ranges: npm @angular/core >=21.2.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 <=18.2.14) - Verified: https://github.com/advisories/GHSA-prjf-86w9-mfqv (GitHub-reviewed advisory GHSA-prjf-86w9-mfqv lists affected ranges: npm @angular/core >=21.2.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =19.0.0-next.0 =0 <=18.2.14) Commands are suggestions: review each one before running it.
Loading voting…