FacturaScripts vulnerable to Reflected Cross-Site Scripting (XSS) via Cookie Manipulation
CVE-2026-27964GHSA-gq5c-rw37-g46c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (facturascripts/facturascripts 2025.81, 2025.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist facturascripts/facturascripts
- Affected
- < 2025.8>= 2025.11, < 2025.81
- Fixed in
- 2025.8, 2025.81
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gq5c-rw37-g46c lists affected ranges: Packagist facturascripts/facturascripts >=0 <=2025.71
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gq5c-rw37-g46c lists affected ranges: Packagist facturascripts/facturascripts >=0 =2025.11 <2025.81
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gq5c-rw37-g46c lists affected ranges: Packagist facturascripts/facturascripts >=0 =2025.11 <2025.81 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.9 · CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N
- EPSS
- CVE-2026-27964: 0.10% estimated exploitation activity in the next 30 days; percentile 1.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A Reflected Cross-Site Scripting (XSS) vulnerability exists in the fsNick cookie parameter. The application reflects the cookie's value directly into the HTML without sanitization.
Details The fsNick cookie is rendered into the DOM without encoding. While the server does reject the modified session and forces a logout, the HTML containing the payload reaches the browser first. This lets the script execute immediately upon load, effectively beating the redirect.
PoC 1. Log in to the application with any valid account. 2. Capture any the GET request . 3. Modify the value of "fsNick" with the following JavaScript: ` alert(window.origin) ` 4. Send the modified request. 5. Result
Impact The payload executes before the session ends, which could potentially allow for a single unauthorized action before the logout.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from osv record GHSA-gq5c-rw37-g46c
- Revision 2 · amended ·
Amended from ghsa record GHSA-gq5c-rw37-g46c
- Revision 1 · created ·
Published from ghsa record GHSA-gq5c-rw37-g46c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-27964 Advisory: FacturaScripts vulnerable to Reflected Cross-Site Scripting (XSS) via Cookie Manipulation IDs: CVE-2026-27964, GHSA-gq5c-rw37-g46c Record: https://patchnext.com/advisories/cve-2026-27964 (revision 3, source checked 31 Oct 2026, 06:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: facturascripts/facturascripts 2025.81, 2025.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist facturascripts/facturascripts: affected < 2025.8; >= 2025.11, < 2025.81; fixed in 2025.8, 2025.81 ## Suggested inspection (read-only) - Packagist facturascripts/facturascripts: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on facturascripts/facturascripts. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gq5c-rw37-g46c (GitHub-reviewed advisory GHSA-gq5c-rw37-g46c lists affected ranges: Packagist facturascripts/facturascripts >=0 <=2025.71) - Verified: https://github.com/advisories/GHSA-gq5c-rw37-g46c (GitHub-reviewed advisory GHSA-gq5c-rw37-g46c lists affected ranges: Packagist facturascripts/facturascripts >=0 =2025.11 <2025.81) - Verified: https://osv.dev/vulnerability/GHSA-gq5c-rw37-g46c (OSV record GHSA-gq5c-rw37-g46c lists affected ranges: Packagist facturascripts/facturascripts >=0 =2025.11 <2025.81 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…