Authlib JWS JWK Header Injection: Signature Verification Bypass
CVE-2026-27962GHSA-wvwj-cvrp-7pv5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (authlib 1.6.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI authlib
- Affected
- < 1.6.9
- Fixed in
- 1.6.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wvwj-cvrp-7pv5 lists affected ranges: PyPI authlib >=0 <=1.6.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wvwj-cvrp-7pv5 lists affected ranges: PyPI authlib >=0 <1.6.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2026-27962: 0.57% estimated exploitation activity in the next 30 days; percentile 47.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description
Summary A JWK Header Injection vulnerability in `authlib`'s JWS implementation allows an unauthenticated attacker to forge arbitrary JWT tokens that pass signature verification. When `key=None` is passed to any JWS deserialization function, the library extracts and uses the cryptographic key embedded in the attacker-controlled JWT `jwk` header field. An attacker can sign a token with their own private key, embed the matching public key in the header, and have the server accept the forged token as cryptographically valid — bypassing authentication and authorization entirely. This behavior violates RFC 7515 §4.1.3 and the validation algorithm defined in RFC 7515 §5.2.
Details Vulnerable file: `authlib/jose/rfc7515/jws.py` Vulnerable method: `JsonWebSignature._prepare_algorithm_key()` Lines: 272–273 ```python elif key is None and "jwk" in header: key = header["jwk"]
← attacker-controlled key used for verification ``` When `key=None` is passed…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 5 · amended ·
Amended from osv record GHSA-wvwj-cvrp-7pv5
- Revision 4 · amended ·
Amended from ghsa record GHSA-wvwj-cvrp-7pv5
- Revision 3 · amended ·
Amended from ghsa record GHSA-wvwj-cvrp-7pv5
- Revision 2 · amended ·
Amended from osv record GHSA-wvwj-cvrp-7pv5
- Revision 1 · created ·
Published from ghsa record GHSA-wvwj-cvrp-7pv5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-27962 Advisory: Authlib JWS JWK Header Injection: Signature Verification Bypass IDs: CVE-2026-27962, GHSA-wvwj-cvrp-7pv5 Record: https://patchnext.com/advisories/cve-2026-27962 (revision 5, source checked 28 Oct 2026, 06:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: authlib 1.6.9. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI authlib: affected < 1.6.9; fixed in 1.6.9 ## Suggested inspection (read-only) - `python -m pip show authlib`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on authlib. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wvwj-cvrp-7pv5 (GitHub-reviewed advisory GHSA-wvwj-cvrp-7pv5 lists affected ranges: PyPI authlib >=0 <=1.6.8) - Verified: https://osv.dev/vulnerability/GHSA-wvwj-cvrp-7pv5 (OSV record GHSA-wvwj-cvrp-7pv5 lists affected ranges: PyPI authlib >=0 <1.6.9 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…