Skip to content

← Actionable
High, CVSS 7.1amended

ormar Pydantic Validation Bypass via __pk_only__ and __excluded__ Kwargs Injection in Model Constructor

CVE-2026-27953GHSA-f964-whrq-44h8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ormar 0.23.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI ormar

    Affected
    <= 0.23.0
    Fixed in
    0.23.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L
EPSS
  • CVE-2026-27953: 1.21% estimated exploitation activity in the next 30 days; percentile 68.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A Pydantic validation bypass in ormar's model constructor allows any unauthenticated user to skip all field validation — type checks, constraints, @fieldvalidator/@modelvalidator decorators, choices enforcement, and required-field checks — by injecting "pkonly": true into a JSON request body. The unvalidated data is subsequently persisted to the database. This affects the canonical usage pattern recommended in ormar's official documentation and examples. A secondary excluded parameter injection uses the same design pattern to selectively nullify arbitrary model fields during construction. Details Root cause: NewBaseModel.init (ormar/models/newbasemodel.py, line 128) pops pkonly directly from user-supplied kwargs before any validation occurs: The pkonly flag was designed as an internal optimization for creating lightweight FK placeholder instances in ormar/fields/foreignkey.py (lines 41, 527). However, because it is extracted from kwargs via .pop() with a False default, any…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-f964-whrq-44h8

  2. Revision 1 · created ·

    Published from osv record GHSA-f964-whrq-44h8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-27953

Advisory: ormar Pydantic Validation Bypass via __pk_only__ and __excluded__ Kwargs Injection in Model Constructor
IDs: CVE-2026-27953, GHSA-f964-whrq-44h8
Record: https://patchnext.com/advisories/cve-2026-27953 (revision 2, source checked 26 Oct 2026, 13:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ormar 0.23.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI ormar: affected <= 0.23.0; fixed in 0.23.1

## Suggested inspection (read-only)
- `python -m pip show ormar`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ormar.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-f964-whrq-44h8 (OSV record GHSA-f964-whrq-44h8 lists affected ranges: PyPI ormar >=0 <0.23.1 (fixed))
- Verified: https://github.com/advisories/GHSA-f964-whrq-44h8 (GitHub-reviewed advisory GHSA-f964-whrq-44h8 lists affected ranges: PyPI ormar >=0 <=0.23.0)

Commands are suggestions: review each one before running it.

Loading voting…