Copyparty vulnerable to reflected XSS via setck parameter
CVE-2026-27948GHSA-62cr-6wp5-q43h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (copyparty 1.20.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI copyparty
- Affected
- < 1.20.9
- Fixed in
- 1.20.9
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-62cr-6wp5-q43h lists affected ranges: PyPI copyparty >=0 <1.20.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-62cr-6wp5-q43h lists affected ranges: PyPI copyparty >=0 <1.20.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
- EPSS
- CVE-2026-27948: 0.20% estimated exploitation activity in the next 30 days; percentile 9.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An XSS allows for reflected cross-site scripting via URL-parameter ?setck=... Details A reflected cross-site scripting (XSS) vulnerability could allow an attacker to execute malicious javascript by tricking users into accessing a malicious link. The worst-case outcome of this is being able to move or delete existing files on the server, or upload new files, using the account of the person who clicks the malicious link. Indicators of Compromise All attempted attacks (successful or not) would be logged to both the copyparty serverlog and the accesslog of the reverseproxy, and are detected by grep -E '[?&]setck=[^&"]%' (the text setck= eventually followed by the % character).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-62cr-6wp5-q43h
- Revision 1 · created ·
Published from osv record GHSA-62cr-6wp5-q43h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-27948 Advisory: Copyparty vulnerable to reflected XSS via setck parameter IDs: CVE-2026-27948, GHSA-62cr-6wp5-q43h Record: https://patchnext.com/advisories/cve-2026-27948 (revision 2, source checked 26 Oct 2026, 13:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: copyparty 1.20.9. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI copyparty: affected < 1.20.9; fixed in 1.20.9 ## Suggested inspection (read-only) - `python -m pip show copyparty`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on copyparty. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-62cr-6wp5-q43h (OSV record GHSA-62cr-6wp5-q43h lists affected ranges: PyPI copyparty >=0 <1.20.9 (fixed)) - Verified: https://github.com/advisories/GHSA-62cr-6wp5-q43h (GitHub-reviewed advisory GHSA-62cr-6wp5-q43h lists affected ranges: PyPI copyparty >=0 <1.20.9) Commands are suggestions: review each one before running it.
Loading voting…