Nginx-UI Vulnerable to Unauthenticated Backup Download with Encryption Key Disclosure
CVE-2026-27944GHSA-g9w5-qffc-6762
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/0xJacky/Nginx-UI 2.3.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/0xJacky/Nginx-UI
- Affected
- < 2.3.3
- Fixed in
- 2.3.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g9w5-qffc-6762 lists affected ranges: Go github.com/0xJacky/Nginx-UI >=0 <2.3.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-27944: 22.84% estimated exploitation activity in the next 30 days; percentile 97.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The /api/backup endpoint is accessible without authentication and discloses the encryption keys required to decrypt the backup in the X-Backup-Security response header. This allows an unauthenticated attacker to download a full system backup containing sensitive data (user credentials, session tokens, SSL private keys, Nginx configurations) and decrypt it immediately. Vulnerability Details | Field | Value | |-------|-------| | CWE | CWE-306: Missing Authentication for Critical Function + CWE-311: Missing Encryption of Sensitive Data | | Affected File | api/backup/router.go | | Affected Function | CreateBackup (lines 8-11 in router, implementation in api/backup/backup.go:13-38) | | Secondary File | internal/backup/backup.go | | CVSS 3.1 | 9.8 (Critical) | | CVSS Vector | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H | Root Cause The vulnerability exists due to two critical security flaws: 1. Missing Authentication on /api/backup Endpoint In api/backup/router.go:9, the backup…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-g9w5-qffc-6762
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-27944 Advisory: Nginx-UI Vulnerable to Unauthenticated Backup Download with Encryption Key Disclosure IDs: CVE-2026-27944, GHSA-g9w5-qffc-6762 Record: https://patchnext.com/advisories/cve-2026-27944 (revision 1, source checked 26 Oct 2026, 15:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/0xJacky/Nginx-UI 2.3.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/0xJacky/Nginx-UI: affected < 2.3.3; fixed in 2.3.3 ## Suggested inspection (read-only) - Go github.com/0xJacky/Nginx-UI: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/0xJacky/Nginx-UI. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g9w5-qffc-6762 (GitHub-reviewed advisory GHSA-g9w5-qffc-6762 lists affected ranges: Go github.com/0xJacky/Nginx-UI >=0 <2.3.3) Commands are suggestions: review each one before running it.
Loading voting…