fast-xml-parser has stack overflow in XMLBuilder with preserveOrder
CVE-2026-27942GHSA-fj3w-jwp8-x2g3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (fast-xml-parser 5.3.8, 4.5.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm fast-xml-parser
- Affected
- >= 5.0.0, < 5.3.8>= 4.0.0-beta.0, < 4.5.4
- Fixed in
- 5.3.8, 4.5.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-fj3w-jwp8-x2g3 lists affected ranges: npm fast-xml-parser >=5.0.0 =4.0.0-beta.0 <4.5.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fj3w-jwp8-x2g3 lists affected ranges: npm fast-xml-parser >=5.0.0 =4.0.0-beta.0 <4.5.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2026-27942: 0.54% estimated exploitation activity in the next 30 days; percentile 45.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Application crashes with stack overflow when user use XML builder with prserveOrder:true for following or similar input Cause: arrToStr was not validating if the input is an array or a string and treating all non-array values as text content. What kind of vulnerability is it? Who is impacted? Patches Yes in 5.3.8 Workarounds Use XML builder with preserveOrder:false or check the input data before passing to builder. References Are there any links users can visit to find out more?
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-fj3w-jwp8-x2g3
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-fj3w-jwp8-x2g3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-27942 Advisory: fast-xml-parser has stack overflow in XMLBuilder with preserveOrder IDs: CVE-2026-27942, GHSA-fj3w-jwp8-x2g3 Record: https://patchnext.com/advisories/cve-2026-27942 (revision 3, source checked 26 Oct 2026, 12:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: fast-xml-parser 5.3.8, 4.5.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm fast-xml-parser: affected >= 5.0.0, < 5.3.8; >= 4.0.0-beta.0, < 4.5.4; fixed in 5.3.8, 4.5.4 ## Suggested inspection (read-only) - `npm ls fast-xml-parser --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fast-xml-parser. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-fj3w-jwp8-x2g3 (OSV record GHSA-fj3w-jwp8-x2g3 lists affected ranges: npm fast-xml-parser >=5.0.0 =4.0.0-beta.0 <4.5.4 (fixed)) - Verified: https://github.com/advisories/GHSA-fj3w-jwp8-x2g3 (GitHub-reviewed advisory GHSA-fj3w-jwp8-x2g3 lists affected ranges: npm fast-xml-parser >=5.0.0 =4.0.0-beta.0 <4.5.4) Commands are suggestions: review each one before running it.
Loading voting…