Vaultwarden has Unauthorized Access via Partial Update API on Another User’s Cipher
CVE-2026-27898GHSA-w9f8-m526-h7fh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vaultwarden 1.35.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io vaultwarden
- Affected
- <= 1.35.3
- Fixed in
- 1.35.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w9f8-m526-h7fh lists affected ranges: crates.io vaultwarden >=0 <=1.35.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2026-27898: 0.19% estimated exploitation activity in the next 30 days; percentile 8.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary In the test environment, it was confirmed that an authenticated regular user can specify another user’s cipherid and call: Even though the standard retrieval API correctly denies access to that cipher, the partial update endpoint returns 200 OK and exposes cipherDetails (including name, notes, data, secureNote, etc.). Description putcipherpartial retrieves the target Cipher but does not perform ownership or access control checks before returning tojson. Authorization checks present in the normal update API are missing here. src/api/core/ciphers.rs:717 By comparison, the standard update API includes an explicit authorization check: src/api/core/ciphers.rs:688 The tojson method does not abort processing when access restrictions are not met; instead, it proceeds to construct and return a detailed response. src/db/models/cipher.rs:175 src/db/models/cipher.rs:335 Preconditions The attacker possesses a valid regular-user JWT (Bearer token). The attacker knows the target (victim)…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-w9f8-m526-h7fh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-27898 Advisory: Vaultwarden has Unauthorized Access via Partial Update API on Another User’s Cipher IDs: CVE-2026-27898, GHSA-w9f8-m526-h7fh Record: https://patchnext.com/advisories/cve-2026-27898 (revision 1, source checked 26 Oct 2026, 15:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vaultwarden 1.35.4. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io vaultwarden: affected <= 1.35.3; fixed in 1.35.4 ## Suggested inspection (read-only) - crates.io vaultwarden: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vaultwarden. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w9f8-m526-h7fh (GitHub-reviewed advisory GHSA-w9f8-m526-h7fh lists affected ranges: crates.io vaultwarden >=0 <=1.35.3) Commands are suggestions: review each one before running it.
Loading voting…