Skip to content

← Actionable
High, CVSS 8.8amended

vLLM has Hardcoded Trust Override in Model Files Enables RCE Despite Explicit User Opt-Out

CVE-2026-27893GHSA-7972-pg2x-xr59

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.18.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI vllm

    Affected
    >= 0.10.1, < 0.18.0
    Fixed in
    0.18.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-27893: 1.37% estimated exploitation activity in the next 30 days; percentile 71.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Two model implementation files hardcode trustremotecode=True when loading sub-components, bypassing the user's explicit --trust-remote-code=False security opt-out. This enables remote code execution via malicious model repositories even when the user has explicitly disabled remote code trust.

Details Affected files (latest main branch): 1. vllm/modelexecutor/models/nemotronvl.py:430 2. vllm/modelexecutor/models/kimik25.py:177 Both pass a hardcoded trustremotecode=True to HuggingFace API calls, overriding the user's global --trust-remote-code=False setting. Relation to prior CVEs: - CVE-2025-66448 fixed automap resolution in vllm/transformersutils/config.py (config loading path) - CVE-2026-22807 fixed broader automap at startup - Both fixes are present in the current code. These hardcoded instances in model files survived both patches — different code paths. Impact Remote code execution. An attacker can craft a malicious model repository that executes arbitrary Python code…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-7972-pg2x-xr59

  2. Revision 1 · created ·

    Published from osv record GHSA-7972-pg2x-xr59

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-27893

Advisory: vLLM has Hardcoded Trust Override in Model Files Enables RCE Despite Explicit User Opt-Out
IDs: CVE-2026-27893, GHSA-7972-pg2x-xr59
Record: https://patchnext.com/advisories/cve-2026-27893 (revision 2, source checked 26 Oct 2026, 13:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vllm 0.18.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI vllm: affected >= 0.10.1, < 0.18.0; fixed in 0.18.0

## Suggested inspection (read-only)
- `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vllm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7972-pg2x-xr59 (OSV record GHSA-7972-pg2x-xr59 lists affected ranges: PyPI vllm >=0.10.1 <0.18.0 (fixed))
- Verified: https://github.com/advisories/GHSA-7972-pg2x-xr59 (GitHub-reviewed advisory GHSA-7972-pg2x-xr59 lists affected ranges: PyPI vllm >=0.10.1 <0.18.0)

Commands are suggestions: review each one before running it.

Loading voting…