Strapi may leak sensitive data via relational filtering due to lack of query sanitization
CVE-2026-27886GHSA-rjg2-95x7-8qmx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@strapi/strapi 5.37.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @strapi/strapi
- Affected
- >= 4.0.0, < 5.37.0
- Fixed in
- 5.37.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rjg2-95x7-8qmx lists affected ranges: npm @strapi/strapi >=4.0.0 <5.37.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rjg2-95x7-8qmx lists affected ranges: npm @strapi/strapi >=4.0.0 <5.37.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N · score source
- EPSS
- CVE-2026-27886: 1.92% estimated exploitation activity in the next 30 days; percentile 79.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary of CVE-2026-27886 Vulnerability Details - CVE: CVE-2026-27886 - CVSS v3.1 Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N (9.3 — Critical) - Affected Versions: @strapi/strapi <=5.36.1 - How to Patch: Immediately update your Strapi to =5.37.0 Description of CVE-2026-27886 Strapi versions prior to 5.37.0 did not sufficiently sanitize query parameters when filtering content via relational fields. An unauthenticated attacker could use the where query parameter on any publicly-accessible content-type with an updatedBy (or other admin-relation) field to perform a boolean-oracle attack against private fields on the joined adminusers table, including the resetPasswordToken field. Extracting an admin reset token via this oracle made full administrative account takeover possible without authentication. When a filter such as where[updatedBy][resetPasswordToken][$startsWith]=a was applied to a public Content API endpoint, the underlying query generation performed…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-rjg2-95x7-8qmx
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-rjg2-95x7-8qmx
- Revision 1 · created ·
Published from ghsa record GHSA-rjg2-95x7-8qmx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-27886 Advisory: Strapi may leak sensitive data via relational filtering due to lack of query sanitization IDs: CVE-2026-27886, GHSA-rjg2-95x7-8qmx Record: https://patchnext.com/advisories/cve-2026-27886 (revision 4, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @strapi/strapi 5.37.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @strapi/strapi: affected >= 4.0.0, < 5.37.0; fixed in 5.37.0 ## Suggested inspection (read-only) - `npm ls @strapi/strapi --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @strapi/strapi. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rjg2-95x7-8qmx (GitHub-reviewed advisory GHSA-rjg2-95x7-8qmx lists affected ranges: npm @strapi/strapi >=4.0.0 <5.37.0) - Verified: https://osv.dev/vulnerability/GHSA-rjg2-95x7-8qmx (OSV record GHSA-rjg2-95x7-8qmx lists affected ranges: npm @strapi/strapi >=4.0.0 <5.37.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…