Skip to content

← Actionable
High, CVSS 7.5

phpMyFAQ Allows Unauthenticated Account Creation via WebAuthn Prepare Endpoint

CVE-2026-27836GHSA-w22q-m2fm-x9f4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (thorsten/phpmyfaq 4.0.18), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2026-27836: 0.45% estimated exploitation activity in the next 30 days; percentile 39.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The WebAuthn prepare endpoint (/api/webauthn/prepare) creates new active user accounts without any authentication, CSRF protection, CAPTCHA, or configuration checks. This allows unauthenticated attackers to create unlimited user accounts even when registration is disabled. Details File: phpmyfaq/src/phpMyFAQ/Controller/Frontend/Api/WebAuthnController.php, lines 63-79 The endpoint: 1. Accepts any POST request with a JSON username field 2. If the username doesn't exist, creates a new active user account 3. Does NOT check if WebAuthn support is enabled (security.enableWebAuthnSupport) 4. Does NOT check if registration is enabled (security.enableRegistration) 5. Does NOT verify CSRF tokens 6. Does NOT require captcha validation 7. Has no rate limiting PoC Impact - Registration bypass: Accounts created even when self-registration is disabled - Username squatting: Reserve usernames before legitimate users - Database exhaustion: Create millions of fake active accounts (DoS) - User…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-w22q-m2fm-x9f4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-27836

Advisory: phpMyFAQ Allows Unauthenticated Account Creation via WebAuthn Prepare Endpoint
IDs: CVE-2026-27836, GHSA-w22q-m2fm-x9f4
Record: https://patchnext.com/advisories/cve-2026-27836 (revision 1, source checked 26 Oct 2026, 14:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: thorsten/phpmyfaq 4.0.18. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist thorsten/phpmyfaq: affected < 4.0.18; fixed in 4.0.18

## Suggested inspection (read-only)
- Packagist thorsten/phpmyfaq: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on thorsten/phpmyfaq.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-w22q-m2fm-x9f4 (GitHub-reviewed advisory GHSA-w22q-m2fm-x9f4 lists affected ranges: Packagist thorsten/phpmyfaq >=0 <4.0.18)

Commands are suggestions: review each one before running it.

Loading voting…