EGroupware has a Remote Code Execution Vulnerability
CVE-2026-27823GHSA-h9qx-v5xp-ph8p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (egroupware/egroupware 26.2.20260224, 23.1.20260224), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist egroupware/egroupware
- Affected
- >= 26.0.20251208, < 26.2.20260224< 23.1.20260224
- Fixed in
- 26.2.20260224, 23.1.20260224
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h9qx-v5xp-ph8p lists affected ranges: Packagist egroupware/egroupware >=26.0.20251208 =0 <23.1.20260224
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-27823: 0.97% estimated exploitation activity in the next 30 days; percentile 62.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A critical vulnerability has been identified in EGroupware that may lead to Remote Code Execution (RCE). The issue allows an authenticated attacker to execute arbitrary commands on the server. If user self-registration is enabled, the vulnerability may be exploitable without prior authentication. The vulnerability stems from improper authorization checks combined with a file write primitive and an arbitrary file read vulnerability, which together enable full system compromise. Details 1. Improper Authorization in SmallPartMediaRecorder::ajaxupload() The vulnerability originates in: EGroupware\SmallParT\Widgets\SmallPartMediaRecorder::ajaxupload() The function attempts to verify whether the current user is a teacher of the specified course ID before allowing a file upload. The critical authorization check ensures that the course access control list (ACL) contains: $requiredacl (self::ROLETEACHER, i.e., 3) However, the courseacl value is derived from user-controlled request…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-h9qx-v5xp-ph8p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-27823 Advisory: EGroupware has a Remote Code Execution Vulnerability IDs: CVE-2026-27823, GHSA-h9qx-v5xp-ph8p Record: https://patchnext.com/advisories/cve-2026-27823 (revision 1, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: egroupware/egroupware 26.2.20260224, 23.1.20260224. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist egroupware/egroupware: affected >= 26.0.20251208, < 26.2.20260224; < 23.1.20260224; fixed in 26.2.20260224, 23.1.20260224 ## Suggested inspection (read-only) - Packagist egroupware/egroupware: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on egroupware/egroupware. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-h9qx-v5xp-ph8p (GitHub-reviewed advisory GHSA-h9qx-v5xp-ph8p lists affected ranges: Packagist egroupware/egroupware >=26.0.20251208 =0 <23.1.20260224) Commands are suggestions: review each one before running it.
Loading voting…