Skip to content

← Actionable
Medium, CVSS 6.6amended

LangGraph: BaseCache Deserialization of Untrusted Data may lead to Remote Code Execution

CVE-2026-27794GHSA-mhr3-j7m5-c7c9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (langgraph-checkpoint 4.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.6 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-27794: 0.84% estimated exploitation activity in the next 30 days; percentile 57.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Context A Remote Code Execution vulnerability exists in LangGraph's caching layer when applications enable cache backends that inherit from BaseCache and opt nodes into caching via CachePolicy. Prior to langgraph-checkpoint 4.0.0, BaseCache defaults to JsonPlusSerializer(picklefallback=True). When msgpack serialization fails, cached values can be deserialized via pickle.loads(...). Who is affected? Caching is not enabled by default. Applications are affected only when: - The application explicitly enables a cache backend (for example by passing cache=... to StateGraph.compile(...) or otherwise configuring a BaseCache implementation) - One or more nodes opt into caching via CachePolicy - The attacker can write to the cache backend (for example a network-accessible Redis instance with weak/no auth, shared cache infrastructure reachable by other tenants/services, or a writable SQLite cache file) Example (enabling a cache backend and opting a node into caching): With picklefallback=True,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mhr3-j7m5-c7c9

  2. Revision 1 · created ·

    Published from osv record GHSA-mhr3-j7m5-c7c9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-27794

Advisory: LangGraph: BaseCache Deserialization of Untrusted Data may lead to Remote Code Execution
IDs: CVE-2026-27794, GHSA-mhr3-j7m5-c7c9
Record: https://patchnext.com/advisories/cve-2026-27794 (revision 2, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: langgraph-checkpoint 4.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI langgraph-checkpoint: affected < 4.0.0; fixed in 4.0.0

## Suggested inspection (read-only)
- `python -m pip show langgraph-checkpoint`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on langgraph-checkpoint.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mhr3-j7m5-c7c9 (OSV record GHSA-mhr3-j7m5-c7c9 lists affected ranges: PyPI langgraph-checkpoint >=0 <4.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-mhr3-j7m5-c7c9 (GitHub-reviewed advisory GHSA-mhr3-j7m5-c7c9 lists affected ranges: PyPI langgraph-checkpoint >=0 <4.0.0)

Commands are suggestions: review each one before running it.

Loading voting…