Angular SSR is vulnerable to SSRF and Header Injection via request handling pipeline
CVE-2026-27739GHSA-x288-3778-4hhx
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @angular/ssr
- Affected
- >= 21.2.0-next.0, < 21.2.0-rc.1>= 21.0.0-next.0, < 21.1.5>= 20.0.0-next.0, < 20.3.17< 19.2.21
- Fixed in
- 21.2.0-rc.1, 21.1.5, 20.3.17, 19.2.21
npm @nguniversal/express-engine
- Affected
- <= 16.2.0
- Fixed in
- no fixed version recorded
npm @nguniversal/common
- Affected
- <= 16.2.0
- Fixed in
- no fixed version recorded
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-x288-3778-4hhx lists affected ranges: npm @angular/ssr >=21.2.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =0 =0 =0 <=16.2.0
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:H/SI:L/SA:N · score source
- EPSS
- CVE-2026-27739: 0.55% estimated exploitation activity in the next 30 days; percentile 46.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A Server-Side Request Forgery (SSRF) vulnerability has been identified in the Angular SSR request handling pipeline. The vulnerability exists because Angular’s internal URL reconstruction logic directly trusts and consumes user-controlled HTTP headers specifically the Host and `X-Forwarded-*` family to determine the application's base origin without any validation of the destination domain. Specifically, the framework didn't have checks for the following: - Host Domain: The `Host` and `X-Forwarded-Host` headers were not checked to belong to a trusted origin. This allows an attacker to redefine the "base" of the application to an arbitrary external domain. - Path & Character Sanitization: The `X-Forwarded-Host` header was not checked for path segments or special characters, allowing manipulation of the base path for all resolved relative URLs. - Port Validation: The `X-Forwarded-Port` header was not…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-x288-3778-4hhx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-27739 Advisory: Angular SSR is vulnerable to SSRF and Header Injection via request handling pipeline IDs: CVE-2026-27739, GHSA-x288-3778-4hhx Record: https://patchnext.com/advisories/cve-2026-27739 (revision 2, source checked 25 Oct 2026, 00:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: @angular/ssr 21.2.0-rc.1, 21.1.5, 20.3.17, 19.2.21. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @angular/ssr: affected >= 21.2.0-next.0, < 21.2.0-rc.1; >= 21.0.0-next.0, < 21.1.5; >= 20.0.0-next.0, < 20.3.17; < 19.2.21; fixed in 21.2.0-rc.1, 21.1.5, 20.3.17, 19.2.21 - npm @nguniversal/express-engine: affected <= 16.2.0 - npm @nguniversal/common: affected <= 16.2.0 ## Suggested inspection (read-only) - `npm ls @angular/ssr --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @nguniversal/express-engine --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @nguniversal/common --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @angular/ssr, @nguniversal/express-engine, @nguniversal/common. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-x288-3778-4hhx (OSV record GHSA-x288-3778-4hhx lists affected ranges: npm @angular/ssr >=21.2.0-next.0 =21.0.0-next.0 =20.0.0-next.0 =0 =0 =0 <=16.2.0) Commands are suggestions: review each one before running it.
Loading voting…