Skip to content

← Actionable
Medium, CVSS 6.4amended

mcp-server-git : Path traversal in git_add allows staging files outside repository boundaries

CVE-2026-27735GHSA-vjqx-cfc4-9h6v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mcp-server-git 2026.1.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N · score source
EPSS
  • CVE-2026-27735: 0.34% estimated exploitation activity in the next 30 days; percentile 28.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In mcp-server-git versions prior to 2026.1.14, the gitadd tool did not validate that file paths provided in the files argument were within the repository boundaries. The tool used GitPython's repo.index.add(, which did not enforce working-tree boundary checks for relative paths. As a result, relative paths containing ../ sequences that resolved outside the repository were accepted and staged into the Git index, potentially allowing sensitive files to be exfiltrated via subsequent commit and push operations. The fix in PR #3164 switches to repo.git.add(), which delegates to the Git CLI and properly rejects out-of-tree paths. Users are advised to upgrade to 2026.1.14 or newer to remediate this issue. mcp-server-git thanks https://hackerone.com/0dd-g for reporting and contributing the fix.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-vjqx-cfc4-9h6v

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-vjqx-cfc4-9h6v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-27735

Advisory: mcp-server-git : Path traversal in git_add allows staging files outside repository boundaries
IDs: CVE-2026-27735, GHSA-vjqx-cfc4-9h6v
Record: https://patchnext.com/advisories/cve-2026-27735 (revision 3, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mcp-server-git 2026.1.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI mcp-server-git: affected < 2026.1.14; fixed in 2026.1.14

## Suggested inspection (read-only)
- `python -m pip show mcp-server-git`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mcp-server-git.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vjqx-cfc4-9h6v (OSV record GHSA-vjqx-cfc4-9h6v lists affected ranges: PyPI mcp-server-git >=0 <2026.1.14 (fixed))
- Verified: https://github.com/advisories/GHSA-vjqx-cfc4-9h6v (GitHub-reviewed advisory GHSA-vjqx-cfc4-9h6v lists affected ranges: PyPI mcp-server-git >=0 <2026.1.14)

Commands are suggestions: review each one before running it.

Loading voting…