Skip to content

← Actionable
High, CVSS 8.6

AVideo has Authenticated Server-Side Request Forgery via downloadURL in aVideoEncoder.json.php

CVE-2026-27732GHSA-h39h-7cvg-q7j6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (wwbn/avideo 22.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-27732: 0.27% estimated exploitation activity in the next 30 days; percentile 19.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Vulnerability Type Authenticated Server-Side Request Forgery (SSRF) Affected Product/Versions AVideo versions prior to 22 (tested on AVideo 21.x). Root Cause Summary The aVideoEncoder.json.php API endpoint accepts a downloadURL parameter and fetches the referenced resource server-side without proper validation or an allow-list. This allows authenticated users to trigger server-side requests to arbitrary URLs (including internal network endpoints). Impact Summary An authenticated attacker can leverage SSRF to interact with internal services and retrieve sensitive data (e.g., internal APIs, metadata services), potentially leading to further compromise depending on the deployment environment. Resolution/Fix This issue has been fixed in AVideo version 22. Users should upgrade to version 22.0 as soon as possible. Credits/Acknowledgement Thanks to Arkadiusz Marta for responsibly reporting this issue. - GitHub Profile: https://github.com/arkmarta/

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-h39h-7cvg-q7j6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-27732

Advisory: AVideo has Authenticated Server-Side Request Forgery via downloadURL in aVideoEncoder.json.php
IDs: CVE-2026-27732, GHSA-h39h-7cvg-q7j6
Record: https://patchnext.com/advisories/cve-2026-27732 (revision 1, source checked 26 Oct 2026, 14:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: wwbn/avideo 22.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist wwbn/avideo: affected <= 21.0; fixed in 22.0

## Suggested inspection (read-only)
- Packagist wwbn/avideo: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on wwbn/avideo.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-h39h-7cvg-q7j6 (GitHub-reviewed advisory GHSA-h39h-7cvg-q7j6 lists affected ranges: Packagist wwbn/avideo >=0 <=21.0)

Commands are suggestions: review each one before running it.

Loading voting…