Budibase: Remote Code Execution via Unsafe eval() in View Filter Map Function (Budibase Cloud)
CVE-2026-27702GHSA-rvhr-26g4-p2r8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (budibase 3.30.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm budibase
- Affected
- < 3.30.4
- Fixed in
- 3.30.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rvhr-26g4-p2r8 lists affected ranges: npm budibase >=0 <3.30.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rvhr-26g4-p2r8 lists affected ranges: npm budibase >=0 <3.30.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:L
- EPSS
- CVE-2026-27702: 0.39% estimated exploitation activity in the next 30 days; percentile 33.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A critical unsafe eval() vulnerability in Budibase's view filtering implementation allows any authenticated user (including free tier accounts) to execute arbitrary JavaScript code on the server. This vulnerability ONLY affects Budibase Cloud (SaaS) - self-hosted deployments use native CouchDB views and are not vulnerable. The vulnerability exists in packages/server/src/db/inMemoryView.ts where user-controlled view map functions are directly evaluated without sanitization. The primary impact comes from what lives inside the pod's environment: the app-service pod runs with secrets baked into its environment variables, including INTERNALAPIKEY, JWTSECRET, CouchDB admin credentials, AWS keys, and more. Using the extracted CouchDB credentials, we verified direct database access, enumerated all tenant databases, and confirmed that user records (email addresses) are readable. Details Root Cause File: packages/server/src/db/inMemoryView.ts:28 Why Only Cloud is Vulnerable: File:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-rvhr-26g4-p2r8
- Revision 2 · amended ·
Amended from osv record GHSA-rvhr-26g4-p2r8
- Revision 1 · created ·
Published from ghsa record GHSA-rvhr-26g4-p2r8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-27702 Advisory: Budibase: Remote Code Execution via Unsafe eval() in View Filter Map Function (Budibase Cloud) IDs: CVE-2026-27702, GHSA-rvhr-26g4-p2r8 Record: https://patchnext.com/advisories/cve-2026-27702 (revision 3, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: budibase 3.30.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm budibase: affected < 3.30.4; fixed in 3.30.4 ## Suggested inspection (read-only) - `npm ls budibase --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on budibase. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rvhr-26g4-p2r8 (GitHub-reviewed advisory GHSA-rvhr-26g4-p2r8 lists affected ranges: npm budibase >=0 <3.30.4) - Verified: https://osv.dev/vulnerability/GHSA-rvhr-26g4-p2r8 (OSV record GHSA-rvhr-26g4-p2r8 lists affected ranges: npm budibase >=0 <3.30.4 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…