Skip to content

← Actionable
High, CVSS 8.2amended

Hono is Vulnerable to Authentication Bypass by IP Spoofing in AWS Lambda ALB conninfo

CVE-2026-27700GHSA-xh87-mx6m-69f3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (hono 4.12.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm hono

    Affected
    >= 4.12.0, < 4.12.2
    Fixed in
    4.12.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
EPSS
  • CVE-2026-27700: 0.27% estimated exploitation activity in the next 30 days; percentile 19.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When using the AWS Lambda adapter (hono/aws-lambda) behind an Application Load Balancer (ALB), the getConnInfo() function incorrectly selected the first value from the X-Forwarded-For header. Because AWS ALB appends the real client IP address to the end of the X-Forwarded-For header, the first value can be attacker-controlled. This could allow IP-based access control mechanisms (such as the ipRestriction middleware) to be bypassed. Details In ALB environments, AWS appends the actual client IP address to the end of any existing X-Forwarded-For header value. However, the previous implementation of getConnInfo() extracted the leftmost IP address: If a client sent: ALB would forward: Since the implementation selected the first value, the spoofed IP address was trusted. This affected applications using: or any custom middleware relying on getConnInfo(c).remote.address for authorization decisions. The issue only affects deployments using the AWS Lambda adapter behind an ALB. API…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-xh87-mx6m-69f3

  2. Revision 1 · created ·

    Published from osv record GHSA-xh87-mx6m-69f3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-27700

Advisory: Hono is Vulnerable to Authentication Bypass by IP Spoofing in AWS Lambda ALB conninfo
IDs: CVE-2026-27700, GHSA-xh87-mx6m-69f3
Record: https://patchnext.com/advisories/cve-2026-27700 (revision 2, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: hono 4.12.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm hono: affected >= 4.12.0, < 4.12.2; fixed in 4.12.2

## Suggested inspection (read-only)
- `npm ls hono --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on hono.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xh87-mx6m-69f3 (OSV record GHSA-xh87-mx6m-69f3 lists affected ranges: npm hono >=4.12.0 <4.12.2 (fixed))
- Verified: https://github.com/advisories/GHSA-xh87-mx6m-69f3 (GitHub-reviewed advisory GHSA-xh87-mx6m-69f3 lists affected ranges: npm hono >=4.12.0 <4.12.2)

Commands are suggestions: review each one before running it.

Loading voting…