baserCMS has an SQL injection vulnerability in its blog post functionality
CVE-2026-27697GHSA-vh89-rjph-2g7p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (baserproject/basercms 5.2.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist baserproject/basercms
- Affected
- <= 5.2.2
- Fixed in
- 5.2.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vh89-rjph-2g7p lists affected ranges: Packagist baserproject/basercms >=0 <=5.2.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-27697: 0.43% estimated exploitation activity in the next 30 days; percentile 37.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
baserCMS has a SQL injection vulnerability in blog posts. Target baserCMS 5.2.2 and earlier versions Vulnerability Malicious SQL may be executed in blog posts. Countermeasures Update to the latest version of baserCMS Please refer to the following page to reference for more information. https://basercms.net/security/JVN52157568 Credits Mirai Matsumoto@Future Secure Wave, Inc.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vh89-rjph-2g7p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-27697 Advisory: baserCMS has an SQL injection vulnerability in its blog post functionality IDs: CVE-2026-27697, GHSA-vh89-rjph-2g7p Record: https://patchnext.com/advisories/cve-2026-27697 (revision 1, source checked 26 Oct 2026, 14:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: baserproject/basercms 5.2.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist baserproject/basercms: affected <= 5.2.2; fixed in 5.2.3 ## Suggested inspection (read-only) - Packagist baserproject/basercms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on baserproject/basercms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vh89-rjph-2g7p (GitHub-reviewed advisory GHSA-vh89-rjph-2g7p lists affected ranges: Packagist baserproject/basercms >=0 <=5.2.2) Commands are suggestions: review each one before running it.
Loading voting…