zae-limiter: DynamoDB hot partition throttling enables per-entity Denial of Service
CVE-2026-27695GHSA-76rv-2r9v-c5m6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (zae-limiter 0.10.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI zae-limiter
- Affected
- <= 0.10.0
- Fixed in
- 0.10.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-76rv-2r9v-c5m6 lists affected ranges: PyPI zae-limiter >=0 <0.10.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-76rv-2r9v-c5m6 lists affected ranges: PyPI zae-limiter >=0 <=0.10.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2026-27695: 0.27% estimated exploitation activity in the next 30 days; percentile 18.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary All rate limit buckets for a single entity share the same DynamoDB partition key (namespace/ENTITY#{id}). A high-traffic entity can exceed DynamoDB's per-partition throughput limits (~1,000 WCU/sec), causing throttling that degrades service for that entity — and potentially co-located entities in the same partition. Details Each acquire() call performs a TransactWriteItems (or UpdateItem in speculative mode) against items sharing the same partition key. For cascade entities, this doubles to 2-4 writes per request (child + parent). At sustained rates above ~500 req/sec for a single entity, DynamoDB's adaptive capacity may not redistribute fast enough, causing ProvisionedThroughputExceededException. The library has no built-in mitigation: - No partition key sharding/salting - No write coalescing or batching - No client-side admission control before hitting DynamoDB - RateLimiterUnavailable is raised but the caller has already been delayed Impact - Availability: High-traffic…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-76rv-2r9v-c5m6
- Revision 1 · created ·
Published from osv record GHSA-76rv-2r9v-c5m6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-27695 Advisory: zae-limiter: DynamoDB hot partition throttling enables per-entity Denial of Service IDs: CVE-2026-27695, GHSA-76rv-2r9v-c5m6 Record: https://patchnext.com/advisories/cve-2026-27695 (revision 2, source checked 26 Oct 2026, 13:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: zae-limiter 0.10.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI zae-limiter: affected <= 0.10.0; fixed in 0.10.1 ## Suggested inspection (read-only) - `python -m pip show zae-limiter`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on zae-limiter. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-76rv-2r9v-c5m6 (OSV record GHSA-76rv-2r9v-c5m6 lists affected ranges: PyPI zae-limiter >=0 <0.10.1 (fixed)) - Verified: https://github.com/advisories/GHSA-76rv-2r9v-c5m6 (GitHub-reviewed advisory GHSA-76rv-2r9v-c5m6 lists affected ranges: PyPI zae-limiter >=0 <=0.10.0) Commands are suggestions: review each one before running it.
Loading voting…