SAP Approuter Vulnerable to HTTP Request Smuggling
CVE-2026-27690GHSA-8m85-wqg7-c529
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@sap/approuter 20.10.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @sap/approuter
- Affected
- < 20.10.0
- Fixed in
- 20.10.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8m85-wqg7-c529 lists affected ranges: npm @sap/approuter >=0 <20.10.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-8m85-wqg7-c529 lists affected ranges: npm @sap/approuter >=0 <20.10.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
- EPSS
- CVE-2026-27690: 0.68% estimated exploitation activity in the next 30 days; percentile 52.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Due to an HTTP Request Smuggling vulnerability in SAP Approuter, an unauthenticated attacker could send a specially crafted HTTP request that leads to request-response desynchronization. This could result in the exposure of user responses and cause the system to become unavailable. This leads to a high impact on confidentiality and availability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-8m85-wqg7-c529
- Revision 2 · amended ·
Amended from osv record GHSA-8m85-wqg7-c529
- Revision 1 · created ·
Published from ghsa record GHSA-8m85-wqg7-c529
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-27690 Advisory: SAP Approuter Vulnerable to HTTP Request Smuggling IDs: CVE-2026-27690, GHSA-8m85-wqg7-c529 Record: https://patchnext.com/advisories/cve-2026-27690 (revision 3, source checked 26 Oct 2026, 13:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @sap/approuter 20.10.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @sap/approuter: affected < 20.10.0; fixed in 20.10.0 ## Suggested inspection (read-only) - `npm ls @sap/approuter --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @sap/approuter. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8m85-wqg7-c529 (GitHub-reviewed advisory GHSA-8m85-wqg7-c529 lists affected ranges: npm @sap/approuter >=0 <20.10.0) - Verified: https://osv.dev/vulnerability/GHSA-8m85-wqg7-c529 (OSV record GHSA-8m85-wqg7-c529 lists affected ranges: npm @sap/approuter >=0 <20.10.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…