Skip to content

← Actionable
Medium, CVSS 5.8amended

OpenClaw: Sandboxed /acp spawn requests could initialize host ACP sessions

CVE-2026-27646GHSA-9q36-67vc-rrwg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.3.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    <= 2026.3.2
    Fixed in
    2026.3.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.8 · CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-27646: 0.11% estimated exploitation activity in the next 30 days; percentile 1.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Sandboxed requester sessions could reach host-side ACP session initialization through /acp spawn. OpenClaw already blocked sessionsspawn({ runtime: "acp" }) from sandboxed sessions, but the slash-command path initialized ACP directly without applying the same host-runtime guard first. Affected Packages / Versions - npm package: openclaw - Affected versions: <= 2026.3.2 - Patched version: = 2026.3.7 Details ACP sessions run on the host, not inside the OpenClaw sandbox. The direct ACP spawn path in src/agents/acp-spawn.ts already denied sandboxed requesters, but /acp spawn in src/auto-reply/reply/commands-acp/lifecycle.ts called initializeSession(...) without first applying the same restriction. In affected versions, an already authorized sender in a sandboxed session could use /acp spawn to cross from sandboxed chat context into host-side ACP runtime initialization when ACP was enabled and a backend was available. Fix Commit(s) - 61000b8e4ded919ca1a825d4700db4cb3fdc56e3 Fix…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-9q36-67vc-rrwg

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-9q36-67vc-rrwg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-27646

Advisory: OpenClaw: Sandboxed /acp spawn requests could initialize host ACP sessions
IDs: CVE-2026-27646, GHSA-9q36-67vc-rrwg
Record: https://patchnext.com/advisories/cve-2026-27646 (revision 3, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.3.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected <= 2026.3.2; fixed in 2026.3.7

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9q36-67vc-rrwg (OSV record GHSA-9q36-67vc-rrwg lists affected ranges: npm openclaw >=0 <2026.3.7 (fixed))
- Verified: https://github.com/advisories/GHSA-9q36-67vc-rrwg (GitHub-reviewed advisory GHSA-9q36-67vc-rrwg lists affected ranges: npm openclaw >=0 <=2026.3.2)

Commands are suggestions: review each one before running it.

Loading voting…