Skip to content

← Actionable
Medium, CVSS 6.1amended

changedetection.io Vulnerable to Reflected XSS in RSS Single Watch Error Response

CVE-2026-27645GHSA-mw8m-398g-h89w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (changedetection-io 0.53.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2026-27645: 0.50% estimated exploitation activity in the next 30 days; percentile 42.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Three security vulnerabilities were identified in changedetection.io through source code review and live validation against a locally deployed Docker instance. All vulnerabilities were confirmed exploitable on the latest version (0.53.6) it was additionally validated at scale against 500 internet-facing instances discovered via FOFA search engine, producing 5K+ confirmed detections using a custom Nuclei template, demonstrating widespread real-world impact. The RSS single-watch endpoint reflects the UUID path parameter directly in the HTTP response body without HTML escaping. Since Flask returns text/html by default for plain string responses, the browser parses and executes injected JavaScript. Details File: changedetectionio/blueprint/rss/singlewatch.py (lines ~45 and ~50) The UUID parameter from the URL path is interpolated into the response body using an f-string with no escaping: Line ~45 Line ~50 Attack Vector The attack requires a valid RSS access token, which is a…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mw8m-398g-h89w

  2. Revision 1 · created ·

    Published from osv record GHSA-mw8m-398g-h89w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-27645

Advisory: changedetection.io Vulnerable to Reflected XSS in RSS Single Watch Error Response
IDs: CVE-2026-27645, GHSA-mw8m-398g-h89w
Record: https://patchnext.com/advisories/cve-2026-27645 (revision 2, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: changedetection-io 0.53.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI changedetection-io: affected <= 0.53.6; fixed in 0.53.7

## Suggested inspection (read-only)
- `python -m pip show changedetection-io`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on changedetection-io.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mw8m-398g-h89w (OSV record GHSA-mw8m-398g-h89w lists affected ranges: PyPI changedetection-io >=0 <0.53.7 (fixed))
- Verified: https://github.com/advisories/GHSA-mw8m-398g-h89w (GitHub-reviewed advisory GHSA-mw8m-398g-h89w lists affected ranges: PyPI changedetection-io >=0 <=0.53.6)

Commands are suggestions: review each one before running it.

Loading voting…