Skip to content

← Actionable
Critical, CVSS 9.8amended

Flask-Reuploaded vulnerable to Remote Code Execution via Server-Side Template Injection

CVE-2026-27641GHSA-65mp-fq8v-56jr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flask-reuploaded 1.5.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-27641: 1.34% estimated exploitation activity in the next 30 days; percentile 71.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A critical path traversal and extension bypass vulnerability in Flask-Reuploaded allows remote attackers to achieve arbitrary file write and remote code execution through Server-Side Template Injection (SSTI).

Patches Flask-Reuploaded has been patched in version 1.5.0

Workarounds 1. Do not pass user input to the `name` parameter 2. Use auto-generated filenames only 3. Implement strict input validation if `name` must be used ```python from werkzeug.utils import secure_filename import os

Sanitize user input before passing to save() safe_name = secure_filename(request.form.get('custom_name'))

Remove path separators safe_name = os.path.basename(safe_name)

Validate extension matches policy if not photos.extension_allowed(photos.get_extension(safe_name)): abort(400) filename = photos.save(file, name=safe_name) ```

Resources The fix is documented in the pull request, see https://github.com/jugmac00/flask-reuploaded/pull/180. A proper write-up was created by…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 5 · amended ·

    Amended from osv record GHSA-65mp-fq8v-56jr

  2. Revision 4 · amended ·

    Amended from ghsa record GHSA-65mp-fq8v-56jr

  3. Revision 3 · amended ·

    Amended from ghsa record GHSA-65mp-fq8v-56jr

  4. Revision 2 · amended ·

    Amended from osv record GHSA-65mp-fq8v-56jr

  5. Revision 1 · created ·

    Published from ghsa record GHSA-65mp-fq8v-56jr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-27641

Advisory: Flask-Reuploaded vulnerable to Remote Code Execution via Server-Side Template Injection
IDs: CVE-2026-27641, GHSA-65mp-fq8v-56jr
Record: https://patchnext.com/advisories/cve-2026-27641 (revision 5, source checked 28 Oct 2026, 06:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flask-reuploaded 1.5.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI flask-reuploaded: affected < 1.5.0; fixed in 1.5.0

## Suggested inspection (read-only)
- `python -m pip show flask-reuploaded`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flask-reuploaded.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-65mp-fq8v-56jr (GitHub-reviewed advisory GHSA-65mp-fq8v-56jr lists affected ranges: PyPI flask-reuploaded >=0 <1.5.0)
- Verified: https://osv.dev/vulnerability/GHSA-65mp-fq8v-56jr (OSV record GHSA-65mp-fq8v-56jr lists affected ranges: PyPI flask-reuploaded >=0 <1.5.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…