@actual-app/sync-server: Missing authorization in sync endpoints allows cross-user budget file access in multi-user mode
CVE-2026-27638GHSA-qmjj-p7m9-wjrv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@actual-app/sync-server 26.2.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 26.2.0
- Fixed in
- 26.2.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qmjj-p7m9-wjrv lists affected ranges: npm @actual-app/sync-server >=0 <26.2.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qmjj-p7m9-wjrv lists affected ranges: npm @actual-app/sync-server >=0 <=26.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2026-27638: 0.34% estimated exploitation activity in the next 30 days; percentile 27.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In multi-user mode (OpenID), the sync API endpoints (/sync/) don't verify that the authenticated user owns or has access to the file being operated on. Any authenticated user can read, modify, and overwrite any other user's budget files by providing their file ID. Affected Code File: packages/sync-server/src/app-sync.ts The validateSessionMiddleware on line 31 confirms the user is authenticated, but individual endpoints only check that the file exists (via verifyFileExists), never that the requesting user owns or has access to the file. Compare with POST /sync/delete-user-file (lines 394-430) which correctly checks: This check is missing from all other endpoints. Affected Endpoints - GET /sync/download-user-file - download any budget file - POST /sync/upload-user-file - overwrite any budget file - POST /sync/sync - read/write sync messages of any file - POST /sync/user-get-key - read encryption key info - POST /sync/user-create-key - change encryption key - POST /sync/reset-user-file…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-qmjj-p7m9-wjrv
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-qmjj-p7m9-wjrv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-27638 Advisory: @actual-app/sync-server: Missing authorization in sync endpoints allows cross-user budget file access in multi-user mode IDs: CVE-2026-27638, GHSA-qmjj-p7m9-wjrv Record: https://patchnext.com/advisories/cve-2026-27638 (revision 3, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @actual-app/sync-server 26.2.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @actual-app/sync-server: affected <= 26.2.0; fixed in 26.2.1 ## Suggested inspection (read-only) - `npm ls @actual-app/sync-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @actual-app/sync-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qmjj-p7m9-wjrv (OSV record GHSA-qmjj-p7m9-wjrv lists affected ranges: npm @actual-app/sync-server >=0 <26.2.1 (fixed)) - Verified: https://github.com/advisories/GHSA-qmjj-p7m9-wjrv (GitHub-reviewed advisory GHSA-qmjj-p7m9-wjrv lists affected ranges: npm @actual-app/sync-server >=0 <=26.2.0) Commands are suggestions: review each one before running it.
Loading voting…