Skip to content

← Actionable
High, CVSS 8.4amended

OpenEXR's CompositeDeepScanLine integer-overflow leads to heap OOB write

CVE-2026-27622GHSA-cr4v-6jm6-4963

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openexr 3.4.6, 3.3.8, 3.2.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI openexr

    Affected
    >= 2.3.0, < 3.2.6>= 3.3.0, < 3.3.8>= 3.4.0, < 3.4.6
    Fixed in
    3.4.6, 3.3.8, 3.2.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.4 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-27622: 0.24% estimated exploitation activity in the next 30 days; percentile 15.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Function: CompositeDeepScanLine::readPixels, reachable from high-level multipart deep read flows (MultiPartInputFile + DeepScanLineInputPart + CompositeDeepScanLine). Vulnerable lines (src/lib/OpenEXR/ImfCompositeDeepScanLine.cpp): - totalsizes[ptr] += counts[j][ptr]; (line ~511) - overallsamplecount += totalsizes[ptr]; (line ~514) - samples[channel].resize (overallsamplecount); (line ~535) Impact: 32-bit sample-count accumulation wrap leads to undersized allocation, then decode writes with true sample volume, causing heap OOB write in genericunpackdeeppointers (src/lib/OpenEXRCore/unpack.c:1374) (DoS/Crash, memory corruption/RCE). Attack scenario: - Attacker provides multipart deep EXR with many parts and very large sample counts per pixel. - Uses compression (RLE/ZIPS) to keep file size relatively small vs decode pressure. - The overflow happens in composite sample accounting (unsigned int), while pointer progression for decode uses larger counters and reaches…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-cr4v-6jm6-4963

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-cr4v-6jm6-4963

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-27622

Advisory: OpenEXR's CompositeDeepScanLine integer-overflow leads to heap OOB write
IDs: CVE-2026-27622, GHSA-cr4v-6jm6-4963
Record: https://patchnext.com/advisories/cve-2026-27622 (revision 3, source checked 26 Oct 2026, 13:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openexr 3.4.6, 3.3.8, 3.2.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI openexr: affected >= 2.3.0, < 3.2.6; >= 3.3.0, < 3.3.8; >= 3.4.0, < 3.4.6; fixed in 3.4.6, 3.3.8, 3.2.6

## Suggested inspection (read-only)
- `python -m pip show openexr`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openexr.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cr4v-6jm6-4963 (OSV record GHSA-cr4v-6jm6-4963 lists affected ranges: PyPI openexr >=2.3.0 =3.3.0 =3.4.0 <3.4.6 (fixed))
- Verified: https://github.com/advisories/GHSA-cr4v-6jm6-4963 (GitHub-reviewed advisory GHSA-cr4v-6jm6-4963 lists affected ranges: PyPI openexr >=2.3.0 =3.3.0 =3.4.0 <3.4.6)

Commands are suggestions: review each one before running it.

Loading voting…