Skip to content

← Actionable
Critical, CVSS 9.3amended

Bugsink is vulnerable to Stored XSS via Pygments fallback in stacktrace rendering

CVE-2026-27614GHSA-vp6q-7m36-pq3w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (bugsink 2.0.13), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI bugsink

    Affected
    < 2.0.13
    Fixed in
    2.0.13

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
EPSS
  • CVE-2026-27614: 0.34% estimated exploitation activity in the next 30 days; percentile 27.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An unauthenticated attacker who can submit events to a Bugsink project can store arbitrary JavaScript in an event. The payload executes only if a user explicitly views the affected Stacktrace in the web UI.

Details When Pygments returns more lines than it was given (a known upstream quirk that triggers with Ruby heredoc-style input), `_pygmentize_lines()` in `theme/templatetags/issues.py:75-77` falls back to returning the raw input lines. `mark_safe()` at line 111-113 is then applied unconditionally - including to those unsanitized raw lines. Since DSN endpoints are public by Sentry protocol, no account is needed to inject. The payload sits in the database until an admin looks at the event. ```python

issues.py:75-77 - fallback path, no escaping if len(pygmented) != len(lines): return lines

raw HTML returned here

issues.py:111-113 - unconditional mark_safe return [mark_safe(line) for line in result] ```

Operational Signals Exploitation attempts are likely to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 5 · amended ·

    Amended from osv record GHSA-vp6q-7m36-pq3w

  2. Revision 4 · amended ·

    Amended from ghsa record GHSA-vp6q-7m36-pq3w

  3. Revision 3 · amended ·

    Amended from ghsa record GHSA-vp6q-7m36-pq3w

  4. Revision 2 · amended ·

    Amended from osv record GHSA-vp6q-7m36-pq3w

  5. Revision 1 · created ·

    Published from ghsa record GHSA-vp6q-7m36-pq3w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-27614

Advisory: Bugsink is vulnerable to Stored XSS via Pygments fallback in stacktrace rendering
IDs: CVE-2026-27614, GHSA-vp6q-7m36-pq3w
Record: https://patchnext.com/advisories/cve-2026-27614 (revision 5, source checked 28 Oct 2026, 06:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: bugsink 2.0.13. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI bugsink: affected < 2.0.13; fixed in 2.0.13

## Suggested inspection (read-only)
- `python -m pip show bugsink`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on bugsink.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vp6q-7m36-pq3w (GitHub-reviewed advisory GHSA-vp6q-7m36-pq3w lists affected ranges: PyPI bugsink >=0 <=2.0.12)
- Verified: https://osv.dev/vulnerability/GHSA-vp6q-7m36-pq3w (OSV record GHSA-vp6q-7m36-pq3w lists affected ranges: PyPI bugsink >=0 <2.0.13 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…