repostat: Reflected Cross-Site Scripting (XSS) via repo prop in RepoCard
CVE-2026-27612GHSA-fm8c-6m29-rp6j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (repostat 1.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm repostat
- Affected
- < 1.0.1
- Fixed in
- 1.0.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-fm8c-6m29-rp6j lists affected ranges: npm repostat >=0 <1.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fm8c-6m29-rp6j lists affected ranges: npm repostat >=0 <1.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2026-27612: 0.23% estimated exploitation activity in the next 30 days; percentile 14.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The RepoCard component is vulnerable to Reflected Cross-Site Scripting (XSS). The vulnerability occurs because the component uses React's dangerouslySetInnerHTML to render the repository name (repo prop) during the loading state without any sanitization. If a developer using this package passes unvalidated user input directly into the repo prop (for example, reading it from a URL query parameter), an attacker can execute arbitrary JavaScript in the context of the user's browser. Proof of Concept Remediation Update to version 1.0.1. The use of dangerouslySetInnerHTML has been removed, and the repo prop is now safely rendered using standard React JSX data binding, which automatically escapes HTML entities.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-fm8c-6m29-rp6j
- Revision 1 · created ·
Published from osv record GHSA-fm8c-6m29-rp6j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-27612 Advisory: repostat: Reflected Cross-Site Scripting (XSS) via repo prop in RepoCard IDs: CVE-2026-27612, GHSA-fm8c-6m29-rp6j Record: https://patchnext.com/advisories/cve-2026-27612 (revision 2, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: repostat 1.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm repostat: affected < 1.0.1; fixed in 1.0.1 ## Suggested inspection (read-only) - `npm ls repostat --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on repostat. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-fm8c-6m29-rp6j (OSV record GHSA-fm8c-6m29-rp6j lists affected ranges: npm repostat >=0 <1.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-fm8c-6m29-rp6j (GitHub-reviewed advisory GHSA-fm8c-6m29-rp6j lists affected ranges: npm repostat >=0 <1.0.1) Commands are suggestions: review each one before running it.
Loading voting…