Rollup 4 has Arbitrary File Write via Path Traversal
CVE-2026-27606GHSA-mw96-cpmx-2vgc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (rollup 4.59.0, 3.30.0, 2.80.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm rollup
- Affected
- < 2.80.0>= 3.0.0, < 3.30.0>= 4.0.0, < 4.59.0
- Fixed in
- 2.80.0, 3.30.0, 4.59.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mw96-cpmx-2vgc lists affected ranges: npm rollup >=0 =3.0.0 =4.0.0 <4.59.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mw96-cpmx-2vgc lists affected ranges: npm rollup >=0 =3.0.0 =4.0.0 <4.59.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2026-27606: 1.65% estimated exploitation activity in the next 30 days; percentile 76.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The Rollup module bundler (specifically v4.x and present in current source) is vulnerable to an Arbitrary File Write via Path Traversal. Insecure file name sanitization in the core engine allows an attacker to control output filenames (e.g., via CLI named inputs, manual chunk aliases, or malicious plugins) and use traversal sequences (../) to overwrite files anywhere on the host filesystem that the build process has permissions for. This can lead to persistent Remote Code Execution (RCE) by overwriting critical system or user configuration files. Details The vulnerability is caused by the combination of two flawed components in the Rollup core: 1. Improper Sanitization: In src/utils/sanitizeFileName.ts, the INVALIDCHARREGEX used to clean user-provided names for chunks and assets excludes the period (.) and forward/backward slashes (/, \). This allows path traversal sequences like ../../ to pass through the sanitizer unmodified. 2. Unsafe Path Resolution: In…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-mw96-cpmx-2vgc
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-mw96-cpmx-2vgc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-27606 Advisory: Rollup 4 has Arbitrary File Write via Path Traversal IDs: CVE-2026-27606, GHSA-mw96-cpmx-2vgc Record: https://patchnext.com/advisories/cve-2026-27606 (revision 3, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: rollup 4.59.0, 3.30.0, 2.80.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm rollup: affected < 2.80.0; >= 3.0.0, < 3.30.0; >= 4.0.0, < 4.59.0; fixed in 2.80.0, 3.30.0, 4.59.0 ## Suggested inspection (read-only) - `npm ls rollup --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on rollup. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mw96-cpmx-2vgc (OSV record GHSA-mw96-cpmx-2vgc lists affected ranges: npm rollup >=0 =3.0.0 =4.0.0 <4.59.0 (fixed)) - Verified: https://github.com/advisories/GHSA-mw96-cpmx-2vgc (GitHub-reviewed advisory GHSA-mw96-cpmx-2vgc lists affected ranges: npm rollup >=0 =3.0.0 =4.0.0 <4.59.0) Commands are suggestions: review each one before running it.
Loading voting…