Caddy: Unicode case-folding length expansion causes incorrect split_path index in FastCGI transport
CVE-2026-27590GHSA-5r3v-vc8m-m96g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/caddyserver/caddy/v2 2.11.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/caddyserver/caddy/v2
- Affected
- < 2.11.1
- Fixed in
- 2.11.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5r3v-vc8m-m96g lists affected ranges: Go github.com/caddyserver/caddy/v2 >=0 <2.11.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2026-27590: 0.61% estimated exploitation activity in the next 30 days; percentile 49.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Caddy's FastCGI path splitting logic computes the split index on a lowercased copy of the request path and then uses that byte index to slice the original path. This is unsafe for Unicode because strings.ToLower() can change UTF-8 byte length for some characters. As a result, Caddy can derive an incorrect SCRIPTNAME/SCRIPTFILENAME and PATHINFO, potentially causing a request that contains .php to execute a different on-disk file than intended (path confusion). In setups where an attacker can control file contents (e.g., upload features), this can lead to unintended PHP execution of non-.php files (potential RCE depending on deployment). Details The issue is in github.com/caddyserver/caddy/modules/caddyhttp/fastcgi.Trasnport.splitPos() (and the subsequent slicing in buildEnv()): The returned index is computed in the byte space of lowerPath, but buildEnv() applies it to the original path: - docURI = path[:splitPos] - pathInfo = path[splitPos:] - scriptName =…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5r3v-vc8m-m96g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-27590 Advisory: Caddy: Unicode case-folding length expansion causes incorrect split_path index in FastCGI transport IDs: CVE-2026-27590, GHSA-5r3v-vc8m-m96g Record: https://patchnext.com/advisories/cve-2026-27590 (revision 1, source checked 26 Oct 2026, 15:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/caddyserver/caddy/v2 2.11.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/caddyserver/caddy/v2: affected < 2.11.1; fixed in 2.11.1 ## Suggested inspection (read-only) - Go github.com/caddyserver/caddy/v2: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/caddyserver/caddy/v2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5r3v-vc8m-m96g (GitHub-reviewed advisory GHSA-5r3v-vc8m-m96g lists affected ranges: Go github.com/caddyserver/caddy/v2 >=0 <2.11.1) Commands are suggestions: review each one before running it.
Loading voting…