ActualBudget server is Missing Authentication for SimpleFIN and Pluggy AI bank sync endpoints
CVE-2026-27584GHSA-m2cq-xjgm-f668
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@actual-app/sync-server 26.2.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 26.2.1
- Fixed in
- 26.2.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m2cq-xjgm-f668 lists affected ranges: npm @actual-app/sync-server >=0 <26.2.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-m2cq-xjgm-f668 lists affected ranges: npm @actual-app/sync-server >=0 <26.2.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N · score source
- EPSS
- CVE-2026-27584: 0.45% estimated exploitation activity in the next 30 days; percentile 39.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Missing authentication middleware in the ActualBudget server component allows any unauthenticated user to query the SimpleFIN and Pluggy.ai integration endpoints and read sensitive bank account balance and transaction information. Impact This vulnerability allows an unauthenticated attacker to read the bank account balance and transaction history of ActualBudget users. This vulnerability impacts all ActualBudget Server users with the SimpleFIN or Pluggy.ai integrations configured. The ActualBudget Server instance must be reachable over the network. Details The ActualBudget server component allows for integration with SimpleFIN and Pluggy.ai services. These services read bank account balances and transaction data from users' banks and return the data to ActualBudget. The affected endpoints facilitate this integration and are intended to be used only by logged in users for the purposes of syncing bank transaction data. The vulnerable source code is in the following files in the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-m2cq-xjgm-f668
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-m2cq-xjgm-f668
- Revision 1 · created ·
Published from ghsa record GHSA-m2cq-xjgm-f668
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-27584 Advisory: ActualBudget server is Missing Authentication for SimpleFIN and Pluggy AI bank sync endpoints IDs: CVE-2026-27584, GHSA-m2cq-xjgm-f668 Record: https://patchnext.com/advisories/cve-2026-27584 (revision 4, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @actual-app/sync-server 26.2.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @actual-app/sync-server: affected < 26.2.1; fixed in 26.2.1 ## Suggested inspection (read-only) - `npm ls @actual-app/sync-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @actual-app/sync-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m2cq-xjgm-f668 (GitHub-reviewed advisory GHSA-m2cq-xjgm-f668 lists affected ranges: npm @actual-app/sync-server >=0 <26.2.1) - Verified: https://osv.dev/vulnerability/GHSA-m2cq-xjgm-f668 (OSV record GHSA-m2cq-xjgm-f668 lists affected ranges: npm @actual-app/sync-server >=0 <26.2.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…