n8n Vulnerable to Stored XSS via Various Nodes
CVE-2026-27578GHSA-2p9h-rqjw-gm92
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (n8n 2.10.1, 2.9.3, 1.123.22), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm n8n
- Affected
- < 1.123.22>= 2.0.0, < 2.9.3>= 2.10.0, < 2.10.1
- Fixed in
- 2.10.1, 2.9.3, 1.123.22
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2p9h-rqjw-gm92 lists affected ranges: npm n8n >=0 =2.0.0 =2.10.0 <2.10.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2p9h-rqjw-gm92 lists affected ranges: npm n8n >=0 =2.0.0 =2.10.0 <2.10.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2026-27578: 0.22% estimated exploitation activity in the next 30 days; percentile 12.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An authenticated user with permission to create or modify workflows could inject arbitrary scripts into pages rendered by the n8n application using different techniques on various nodes (Form Trigger node, Chat Trigger node, Send & Wait node, Webhook Node, and Chat Node). Scripts injected by a malicious workflow execute in the browser of any user who visits the affected page, enabling session hijacking and account takeover. Patches The issues have been fixed in n8n versions 2.10.1, 2.9.3, and 1.123.22. Users should upgrade to one of these versions or later to remediate the vulnerability. Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: - Limit workflow creation and editing permissions to fully trusted users only. - Disable the Webhook node by adding n8n-nodes-base.webhook to the NODESEXCLUDE environment variable. These workarounds do not fully remediate the risk and should only be used as short-term…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-2p9h-rqjw-gm92
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-2p9h-rqjw-gm92
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-27578 Advisory: n8n Vulnerable to Stored XSS via Various Nodes IDs: CVE-2026-27578, GHSA-2p9h-rqjw-gm92 Record: https://patchnext.com/advisories/cve-2026-27578 (revision 3, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: n8n 2.10.1, 2.9.3, 1.123.22. A vendor fix does not mean a deployment is fixed. ## Affected components - npm n8n: affected < 1.123.22; >= 2.0.0, < 2.9.3; >= 2.10.0, < 2.10.1; fixed in 2.10.1, 2.9.3, 1.123.22 ## Suggested inspection (read-only) - `npm ls n8n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on n8n. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2p9h-rqjw-gm92 (OSV record GHSA-2p9h-rqjw-gm92 lists affected ranges: npm n8n >=0 =2.0.0 =2.10.0 <2.10.1 (fixed)) - Verified: https://github.com/advisories/GHSA-2p9h-rqjw-gm92 (GitHub-reviewed advisory GHSA-2p9h-rqjw-gm92 lists affected ranges: npm n8n >=0 =2.0.0 =2.10.0 <2.10.1) Commands are suggestions: review each one before running it.
Loading voting…