OneUptime:: node:vm sandbox escape in probe allows any project member to achieve RCE
CVE-2026-27574GHSA-v264-xqh4-9xmm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@oneuptime/common 10.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 10.0.0
- Fixed in
- 10.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v264-xqh4-9xmm lists affected ranges: npm @oneuptime/common >=0 <10.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v264-xqh4-9xmm lists affected ranges: npm @oneuptime/common >=0 <10.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-27574: 0.56% estimated exploitation activity in the next 30 days; percentile 46.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary OneUptime lets project members write custom JavaScript that runs inside monitors. The problem is it executes that code using Node.js's built-in vm module, which Node.js itself documents as "not a security mechanism — do not use it to run untrusted code." The classic one-liner escape gives full access to the underlying process, and since the probe runs with host networking and holds all cluster credentials in its environment, this turns into a full cluster compromise for anyone who can register an account. Details The vulnerable code is in Common/Server/Utils/VM/VMRunner.ts at line 55: The JavaScript that reaches this call comes straight from the monitor's customCode field, which is only validated as Zod.string().optional() in Common/Types/Monitor/MonitorStep.ts:531. No AST analysis, no keyword filtering, nothing — just a string that goes directly into vm.runInContext(). Both CustomCodeMonitor.ts and SyntheticMonitor.ts import VMRunner directly inside the probe process. So…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-v264-xqh4-9xmm
- Revision 2 · amended ·
Amended from osv record GHSA-v264-xqh4-9xmm
- Revision 1 · created ·
Published from ghsa record GHSA-v264-xqh4-9xmm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-27574 Advisory: OneUptime:: node:vm sandbox escape in probe allows any project member to achieve RCE IDs: CVE-2026-27574, GHSA-v264-xqh4-9xmm Record: https://patchnext.com/advisories/cve-2026-27574 (revision 3, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @oneuptime/common 10.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @oneuptime/common: affected < 10.0.0; fixed in 10.0.0 ## Suggested inspection (read-only) - `npm ls @oneuptime/common --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @oneuptime/common. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v264-xqh4-9xmm (GitHub-reviewed advisory GHSA-v264-xqh4-9xmm lists affected ranges: npm @oneuptime/common >=0 <10.0.0) - Verified: https://osv.dev/vulnerability/GHSA-v264-xqh4-9xmm (OSV record GHSA-v264-xqh4-9xmm lists affected ranges: npm @oneuptime/common >=0 <10.0.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…