nats-server websockets are vulnerable to pre-auth memory DoS
CVE-2026-27571GHSA-qrvq-68c2-7grw
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/nats-io/nats-server/v2
- Affected
- < 2.11.12>= 2.12.0-RC.1, < 2.12.3
- Fixed in
- 2.11.12, 2.12.3
Go github.com/nats-io/nats-server
- Affected
- <= 1.4.1
- Fixed in
- no fixed version recorded
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qrvq-68c2-7grw lists affected ranges: Go github.com/nats-io/nats-server/v2 >=0 =2.12.0-RC.1 =0 <=1.4.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-27571: 0.54% estimated exploitation activity in the next 30 days; percentile 45.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The WebSockets handling of NATS messages handles compressed messages via the WebSockets negotiated compression. The implementation bound the memory size of a NATS message but did not independently bound the memory consumption of the memory stream when constructing a NATS message which might then fail validation for size reasons. An attacker can use a compression bomb to cause excessive memory consumption, often resulting in the operating system terminating the server process. The use of compression is negotiated before authentication, so this does not require valid NATS credentials to exploit. The fix was to bounds the decompression to fail once the message was too large, instead of continuing on. Patches This was released in nats-server without being highlighted as a security issue. It should have been, this was an oversight. Per the NATS security policy, because this does not require a valid user, it is CVE-worthy. This was fixed in the v2.11 series with v2.11.12 and in the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qrvq-68c2-7grw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-27571 Advisory: nats-server websockets are vulnerable to pre-auth memory DoS IDs: CVE-2026-27571, GHSA-qrvq-68c2-7grw Record: https://patchnext.com/advisories/cve-2026-27571 (revision 1, source checked 26 Oct 2026, 15:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: github.com/nats-io/nats-server/v2 2.12.3, 2.11.12. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/nats-io/nats-server/v2: affected < 2.11.12; >= 2.12.0-RC.1, < 2.12.3; fixed in 2.11.12, 2.12.3 - Go github.com/nats-io/nats-server: affected <= 1.4.1 ## Suggested inspection (read-only) - Go github.com/nats-io/nats-server/v2: check the installed version with your package manager. - Go github.com/nats-io/nats-server: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/nats-io/nats-server/v2, github.com/nats-io/nats-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qrvq-68c2-7grw (GitHub-reviewed advisory GHSA-qrvq-68c2-7grw lists affected ranges: Go github.com/nats-io/nats-server/v2 >=0 =2.12.0-RC.1 =0 <=1.4.1) Commands are suggestions: review each one before running it.
Loading voting…