Skip to content

← Actionable
Medium, CVSS 6.5amended

Payload: Server-Side Request Forgery (SSRF) in External File URL Uploads

CVE-2026-27567GHSA-hhfx-5x8j-f5f6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (payload 3.75.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm payload

    Affected
    < 3.75.0
    Fixed in
    3.75.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-27567: 0.34% estimated exploitation activity in the next 30 days; percentile 26.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A Server-Side Request Forgery (SSRF) vulnerability exists in Payload's external file upload functionality. When processing external URLs for file uploads, insufficient validation of HTTP redirects could allow an authenticated attacker to access internal network resources. Users are affected if ALL of these are true: - Payload version < v3.75.0 - At least one collection with upload enabled - A user has create access to that upload-enabled collection An authenticated user with upload collection write permissions could potentially access internal services. Response content from internal services could be retrieved through the application. Patches This vulnerability has been patched in v3.75.0. Users should upgrade to v3.75.0 or later. Workarounds If users cannot upgrade immediately, they can mitigate this vulnerability by disabling external file uploads via the disableExternalFile upload collection option, or by restricting create access on upload-enabled collections to trusted…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-hhfx-5x8j-f5f6

  2. Revision 1 · created ·

    Published from osv record GHSA-hhfx-5x8j-f5f6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-27567

Advisory: Payload: Server-Side Request Forgery (SSRF) in External File URL Uploads
IDs: CVE-2026-27567, GHSA-hhfx-5x8j-f5f6
Record: https://patchnext.com/advisories/cve-2026-27567 (revision 2, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: payload 3.75.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm payload: affected < 3.75.0; fixed in 3.75.0

## Suggested inspection (read-only)
- `npm ls payload --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on payload.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hhfx-5x8j-f5f6 (OSV record GHSA-hhfx-5x8j-f5f6 lists affected ranges: npm payload >=0 <3.75.0 (fixed))
- Verified: https://github.com/advisories/GHSA-hhfx-5x8j-f5f6 (GitHub-reviewed advisory GHSA-hhfx-5x8j-f5f6 lists affected ranges: npm payload >=0 <3.75.0)

Commands are suggestions: review each one before running it.

Loading voting…