Skip to content

← Actionable
Medium, CVSS 4.7amended

Lettermint Node.js SDK leaks email properties to unintended recipients when client instance is reused

CVE-2026-27492GHSA-49pc-8936-wvfp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (lettermint 1.5.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.7 · CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-27492: 0.19% estimated exploitation activity in the next 30 days; percentile 8.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Email properties (such as to, subject, html, text, and attachments) are not reset between sends when a single client instance is reused across multiple .send() calls. This can cause properties from a previous send to leak into a subsequent one, potentially delivering content or recipient addresses to unintended parties. Applications sending emails to different recipients in sequence — such as transactional flows like password resets or notifications — are affected. Patches Yes, the issue has been patched. Users should upgrade to v1.5.1 or later. Workarounds If upgrading immediately is not possible, instantiate a new client for each send: This ensures no state is carried over between sends.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-49pc-8936-wvfp

  2. Revision 1 · created ·

    Published from osv record GHSA-49pc-8936-wvfp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-27492

Advisory: Lettermint Node.js SDK leaks email properties to unintended recipients when client instance is reused
IDs: CVE-2026-27492, GHSA-49pc-8936-wvfp
Record: https://patchnext.com/advisories/cve-2026-27492 (revision 2, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: lettermint 1.5.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm lettermint: affected < 1.5.1; fixed in 1.5.1

## Suggested inspection (read-only)
- `npm ls lettermint --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on lettermint.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-49pc-8936-wvfp (OSV record GHSA-49pc-8936-wvfp lists affected ranges: npm lettermint >=0 <1.5.1 (fixed))
- Verified: https://github.com/advisories/GHSA-49pc-8936-wvfp (GitHub-reviewed advisory GHSA-49pc-8936-wvfp lists affected ranges: npm lettermint >=0 <1.5.1)

Commands are suggestions: review each one before running it.

Loading voting…