Skip to content

← Actionable
High, CVSS 8.7amended

onnx Vulnerable to Path Traversal via Symlink

CVE-2026-27489GHSA-3r9x-f23j-gc73

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (onnx 1.21.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI onnx

    Affected
    < 1.21.0
    Fixed in
    1.21.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-27489: 0.62% estimated exploitation activity in the next 30 days; percentile 49.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A path traversal vulnerability via symlink allows to read arbitrary files outside model or user-provided directory.

Details The following check for symlink is ineffective and it is possible to point a symlink to an arbitrary location on the file system: https://github.com/onnx/onnx/blob/336652a4b2ab1e530ae02269efa7038082cef250/onnx/checker.cc#L1024-L1033 `std::filesystem::is_regular_file` performs a `status(p)` call on the provided path, which follows symbolic links to determine the file type, meaning it will return true if the target of a symlink is a regular file.

PoC ```python

Create a demo model with external data import os import numpy as np import onnx from onnx import helper, TensorProto, numpy_helper def create_onnx_model(output_path="model.onnx"): weight_matrix = np.random.randn(1000, 1000).astype(np.float32) X = helper.make_tensor_value_info("X", TensorProto.FLOAT, [1, 1000]) Y = helper.make_tensor_value_info("Y", TensorProto.FLOAT, [1, 1000]) W =…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 5 · amended ·

    Amended from osv record GHSA-3r9x-f23j-gc73

  2. Revision 4 · amended ·

    Amended from ghsa record GHSA-3r9x-f23j-gc73

  3. Revision 3 · amended ·

    Amended from ghsa record GHSA-3r9x-f23j-gc73

  4. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  5. Revision 1 · created ·

    Published from osv record GHSA-3r9x-f23j-gc73

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-27489

Advisory: onnx Vulnerable to Path Traversal via Symlink
IDs: CVE-2026-27489, GHSA-3r9x-f23j-gc73
Record: https://patchnext.com/advisories/cve-2026-27489 (revision 5, source checked 4 Nov 2026, 06:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: onnx 1.21.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI onnx: affected < 1.21.0; fixed in 1.21.0

## Suggested inspection (read-only)
- `python -m pip show onnx`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on onnx.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3r9x-f23j-gc73 (OSV record GHSA-3r9x-f23j-gc73 lists affected ranges: PyPI onnx >=0 <1.21.0 (fixed))
- Verified: https://github.com/advisories/GHSA-3r9x-f23j-gc73 (GitHub-reviewed advisory GHSA-3r9x-f23j-gc73 lists affected ranges: PyPI onnx >=0 <=1.20.0)

Commands are suggestions: review each one before running it.

Loading voting…