OpenClaw: Prevent shell injection in macOS keychain credential write
CVE-2026-27487GHSA-4564-pvr2-qq4h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- < 2026.2.14
- Fixed in
- 2026.2.14
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4564-pvr2-qq4h lists affected ranges: npm openclaw >=0 <2026.2.14 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4564-pvr2-qq4h lists affected ranges: npm openclaw >=0 <2026.2.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:L
- EPSS
- CVE-2026-27487: 1.37% estimated exploitation activity in the next 30 days; percentile 71.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary On macOS, the Claude CLI keychain credential refresh path constructed a shell command to write the updated JSON blob into Keychain via security add-generic-password -w .... Because OAuth tokens are user-controlled data, this created an OS command injection risk. The fix avoids invoking a shell by using execFileSync("security", argv) and passing the updated keychain payload as a literal argument. Affected Packages / Versions - Package: openclaw (npm) - Platform: macOS only - Affected versions: <= 2026.2.13 Fix - Patched version: = 2026.2.14 (next release) - Fix PR: #15924 - Fix commits (merged to main): - 9dce3d8bf83f13c067bc3c32291643d2f1f10a06 - 66d7178f2d6f9d60abad35797f97f3e61389b70c - b908388245764fb3586859f44d1dff5372b19caf Thanks @aether-ai-agent for reporting.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-4564-pvr2-qq4h
- Revision 1 · created ·
Published from osv record GHSA-4564-pvr2-qq4h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-27487 Advisory: OpenClaw: Prevent shell injection in macOS keychain credential write IDs: CVE-2026-27487, GHSA-4564-pvr2-qq4h Record: https://patchnext.com/advisories/cve-2026-27487 (revision 2, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.14. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected < 2026.2.14; fixed in 2026.2.14 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4564-pvr2-qq4h (OSV record GHSA-4564-pvr2-qq4h lists affected ranges: npm openclaw >=0 <2026.2.14 (fixed)) - Verified: https://github.com/advisories/GHSA-4564-pvr2-qq4h (GitHub-reviewed advisory GHSA-4564-pvr2-qq4h lists affected ranges: npm openclaw >=0 <2026.2.14) Commands are suggestions: review each one before running it.
Loading voting…