Skip to content

← Actionable
Medium, CVSS 4.6amended

OpenClaw: Reject symlinks in local skill packaging script

CVE-2026-27485GHSA-r6h2-5gqq-v5v6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.19), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    <= 2026.2.18
    Fixed in
    2026.2.19

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
4.6 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-27485: 0.25% estimated exploitation activity in the next 30 days; percentile 16.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Vulnerability skills/skill-creator/scripts/packageskill.py (a local helper script used when authors package skills) previously followed symlinks while building .skill archives. If an author runs this script on a crafted local skill directory containing symlinks to files outside the skill root, the resulting archive can include unintended file contents. Severity and Exposure - Severity: Low - Execution context: local/manual workflow only (skill author packaging step) - No remote trigger: this is not reachable via normal OpenClaw gateway/chat runtime paths - No extraction Zip Slip in this finding: this issue is limited to packaging-time symlink following Impact - Potential unintentional disclosure of local files from the packaging machine into a generated .skill artifact. - Requires local execution of the packaging script on attacker-controlled skill contents. Affected Components - skills/skill-creator/scripts/packageskill.py Affected Packages / Versions - Package: openclaw (npm) -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-r6h2-5gqq-v5v6

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-r6h2-5gqq-v5v6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-27485

Advisory: OpenClaw: Reject symlinks in local skill packaging script
IDs: CVE-2026-27485, GHSA-r6h2-5gqq-v5v6
Record: https://patchnext.com/advisories/cve-2026-27485 (revision 3, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.19. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected <= 2026.2.18; fixed in 2026.2.19

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-r6h2-5gqq-v5v6 (OSV record GHSA-r6h2-5gqq-v5v6 lists affected ranges: npm openclaw >=0 <2026.2.19 (fixed))
- Verified: https://github.com/advisories/GHSA-r6h2-5gqq-v5v6 (GitHub-reviewed advisory GHSA-r6h2-5gqq-v5v6 lists affected ranges: npm openclaw >=0 <=2026.2.18)

Commands are suggestions: review each one before running it.

Loading voting…