OpenClaw Discord moderation authorization used untrusted sender identity in tool-driven flows
CVE-2026-27484GHSA-wh94-p5m6-mr7j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.18), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm openclaw
- Affected
- < 2026.2.18
- Fixed in
- 2026.2.18
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wh94-p5m6-mr7j lists affected ranges: npm openclaw >=0 <2026.2.18 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wh94-p5m6-mr7j lists affected ranges: npm openclaw >=0 <2026.2.18
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-27484: 0.22% estimated exploitation activity in the next 30 days; percentile 12.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Overview Discord moderation action handling (timeout, kick, ban) used sender identity from request parameters in tool-driven flows, instead of trusted runtime sender context. Impact In setups where Discord moderation actions are enabled and the bot has the necessary guild permissions, a non-admin user could request moderation actions by spoofing sender identity fields. Affected Packages / Versions - Package: openclaw (npm) - Latest published affected version (as of 2026-02-19): 2026.2.17 - Affected range: <=2026.2.17 - Fixed in planned next release: 2026.2.18 Fix - Moderation authorization now uses trusted sender context (requesterSenderId) instead of untrusted action params. - Added permission checks for required guild capabilities per action. Fix Commit(s) - 775816035ecc6bb243843f8000c9a58ff609e32d Thanks @aether-ai-agent for reporting.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-wh94-p5m6-mr7j
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-wh94-p5m6-mr7j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-27484 Advisory: OpenClaw Discord moderation authorization used untrusted sender identity in tool-driven flows IDs: CVE-2026-27484, GHSA-wh94-p5m6-mr7j Record: https://patchnext.com/advisories/cve-2026-27484 (revision 3, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.18. A vendor fix does not mean a deployment is fixed. ## Affected components - npm openclaw: affected < 2026.2.18; fixed in 2026.2.18 ## Suggested inspection (read-only) - `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openclaw. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wh94-p5m6-mr7j (OSV record GHSA-wh94-p5m6-mr7j lists affected ranges: npm openclaw >=0 <2026.2.18 (fixed)) - Verified: https://github.com/advisories/GHSA-wh94-p5m6-mr7j (GitHub-reviewed advisory GHSA-wh94-p5m6-mr7j lists affected ranges: npm openclaw >=0 <2026.2.18) Commands are suggestions: review each one before running it.
Loading voting…