Skip to content

← Actionable
Critical, CVSS 9.1

Unity Catalog has a JWT Issuer Validation Bypass tht Allows Complete User Impersonation

CVE-2026-27478GHSA-qqcj-rghw-829x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.unitycatalog:unitycatalog-server 0.4.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-27478: 0.19% estimated exploitation activity in the next 30 days; percentile 8.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Context: A critical authentication bypass vulnerability exists in the Unity Catalog token exchange endpoint (/api/1.0/unity-control/auth/tokens). The endpoint extracts the issuer (iss) claim from incoming JWTs and uses it to dynamically fetch the JWKS endpoint for signature validation without validating that the issuer is a trusted identity provider. Way to exploit: An attacker can exploit this by: 1. Hosting their own OIDC-compliant server with a valid JWKS endpoint 2. Signing a JWT with their own private key, setting the iss claim to their server 3. Setting the sub/email claim to any known user in the Unity Catalog system 4. Exchanging this crafted token for a valid internal access token This results in complete impersonation of any user in the system, granting access to all catalogs, schemas, tables, and other resources that user has permissions to. Additionally, the implementation does not validate the audience (aud) claim, allowing tokens intended for other services to be used.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-qqcj-rghw-829x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-27478

Advisory: Unity Catalog has a JWT Issuer Validation Bypass tht Allows Complete User Impersonation
IDs: CVE-2026-27478, GHSA-qqcj-rghw-829x
Record: https://patchnext.com/advisories/cve-2026-27478 (revision 1, source checked 26 Oct 2026, 16:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.unitycatalog:unitycatalog-server 0.4.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.unitycatalog:unitycatalog-server: affected <= 0.4.0; fixed in 0.4.1

## Suggested inspection (read-only)
- Maven io.unitycatalog:unitycatalog-server: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.unitycatalog:unitycatalog-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qqcj-rghw-829x (GitHub-reviewed advisory GHSA-qqcj-rghw-829x lists affected ranges: Maven io.unitycatalog:unitycatalog-server >=0 <=0.4.0)

Commands are suggestions: review each one before running it.

Loading voting…