Skip to content

← Actionable
Critical, CVSS 9.3

Apache Artemis and Apache ActiveMQ Artemis are Missing Authentication for Critical Functions

CVE-2026-27446GHSA-fw88-pf9m-p947

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.apache.artemis:artemis-server

    Affected
    >= 2.50.0, < 2.52.0
    Fixed in
    2.52.0
  • Maven org.apache.activemq:artemis-server

    Affected
    >= 2.11.0, <= 2.44.0
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:L/SC:L/SI:L/SA:L · score source
EPSS
  • CVE-2026-27446: 11.40% estimated exploitation activity in the next 30 days; percentile 96.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Missing Authentication for Critical Function (CWE-306) vulnerability in Apache Artemis, Apache ActiveMQ Artemis. An unauthenticated remote attacker can use the Core protocol to force a target broker to establish an outbound Core federation connection to an attacker-controlled rogue broker. This could potentially result in message injection into any queue and/or message exfiltration from any queue via the rogue broker. This impacts environments that allow both: - Incoming Core protocol connections from untrusted sources to the broker - Outgoing Core protocol connections from the broker to untrusted targets This issue affects: - Apache Artemis from 2.50.0 through 2.51.0 - Apache ActiveMQ Artemis from 2.11.0 through 2.44.0. Users are recommended to upgrade to Apache Artemis version 2.52.0, which fixes the issue. The issue can be mitigated by either of the following: - Remove Core protocol support from any acceptor receiving connections from untrusted sources. Incoming Core protocol…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-fw88-pf9m-p947

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-27446

Advisory: Apache Artemis and Apache ActiveMQ Artemis are Missing Authentication for Critical Functions
IDs: CVE-2026-27446, GHSA-fw88-pf9m-p947
Record: https://patchnext.com/advisories/cve-2026-27446 (revision 1, source checked 26 Oct 2026, 16:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: org.apache.artemis:artemis-server 2.52.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.artemis:artemis-server: affected >= 2.50.0, < 2.52.0; fixed in 2.52.0
- Maven org.apache.activemq:artemis-server: affected >= 2.11.0, <= 2.44.0

## Suggested inspection (read-only)
- Maven org.apache.artemis:artemis-server: check the installed version with your package manager.
- Maven org.apache.activemq:artemis-server: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.artemis:artemis-server, org.apache.activemq:artemis-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-fw88-pf9m-p947 (GitHub-reviewed advisory GHSA-fw88-pf9m-p947 lists affected ranges: Maven org.apache.activemq:artemis-server >=2.11.0 =2.50.0 <2.52.0)

Commands are suggestions: review each one before running it.

Loading voting…