Vaadin Vulnerable to Authentication Bypass When Accessing the /VAADIN Endpoint Without a Trailing Slash
CVE-2026-2742GHSA-rjgh-wgc7-m37j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.vaadin:flow-server 25.0.2, 24.9.8, 23.6.7, 14.14.1; com.vaadin:vaadin 25.0.2, 24.9.8, 23.6.7, 14.14.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.vaadin:flow-server
- Affected
- < 14.14.1>= 23.0.0, < 23.6.7>= 24.0.0, < 24.9.8>= 25.0.0, < 25.0.2
- Fixed in
- 14.14.1, 23.6.7, 25.0.2, 24.9.8
Maven com.vaadin:vaadin
- Affected
- >= 25.0.0, < 25.0.2>= 24.0.0, < 24.9.8>= 23.0.0, < 23.6.7< 14.14.1
- Fixed in
- 14.14.1, 23.6.7, 25.0.2, 24.9.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rjgh-wgc7-m37j lists affected ranges: Maven com.vaadin:flow-server >=0 =23.0.0 =24.0.0 =25.0.0 =25.0.0 =24.0.0 =23.0.0 =0 <14.14.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L/S:N/AU:Y/R:A/V:D/RE:L/U:Amber · score source
- EPSS
- CVE-2026-2742: 0.41% estimated exploitation activity in the next 30 days; percentile 35.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An authentication bypass vulnerability exists in Vaadin 14.0.0 through 14.14.0, 23.0.0 through 23.6.6, 24.0.0 through 24.9.7 and 25.0.0 through 25.0.1, applications using Spring Security due to inconsistent path pattern matching of reserved framework paths. Accessing the /VAADIN endpoint without a trailing slash bypasses security filters, and allowing unauthenticated users to trigger framework initialization and create sessions without proper authorization. Users of affected versions using Spring Security should upgrade as follows: 14.0.0-14.14.0 upgrade to 14.14.1, 23.0.0-23.6.6 to 23.6.7, 24.0.0 - 24.9.7 to 24.9.8, and 25.0.0-25.0.1 upgrade to 25.0.2 or newer. Please note that Vaadin versions 10-13 and 15-22 are no longer supported and users should update either to the latest 14, 23, 24, 25 version.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rjgh-wgc7-m37j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-2742 Advisory: Vaadin Vulnerable to Authentication Bypass When Accessing the /VAADIN Endpoint Without a Trailing Slash IDs: CVE-2026-2742, GHSA-rjgh-wgc7-m37j Record: https://patchnext.com/advisories/cve-2026-2742 (revision 1, source checked 26 Oct 2026, 16:44 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.vaadin:flow-server 25.0.2, 24.9.8, 23.6.7, 14.14.1; com.vaadin:vaadin 25.0.2, 24.9.8, 23.6.7, 14.14.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.vaadin:flow-server: affected < 14.14.1; >= 23.0.0, < 23.6.7; >= 24.0.0, < 24.9.8; >= 25.0.0, < 25.0.2; fixed in 14.14.1, 23.6.7, 25.0.2, 24.9.8 - Maven com.vaadin:vaadin: affected >= 25.0.0, < 25.0.2; >= 24.0.0, < 24.9.8; >= 23.0.0, < 23.6.7; < 14.14.1; fixed in 14.14.1, 23.6.7, 25.0.2, 24.9.8 ## Suggested inspection (read-only) - Maven com.vaadin:flow-server: check the installed version with your package manager. - Maven com.vaadin:vaadin: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.vaadin:flow-server, com.vaadin:vaadin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rjgh-wgc7-m37j (GitHub-reviewed advisory GHSA-rjgh-wgc7-m37j lists affected ranges: Maven com.vaadin:flow-server >=0 =23.0.0 =24.0.0 =25.0.0 =25.0.0 =24.0.0 =23.0.0 =0 <14.14.1) Commands are suggestions: review each one before running it.
Loading voting…