Skip to content

← Actionable
Medium, CVSS 5.5amended

bn.js affected by an infinite loop

CVE-2026-2739GHSA-378v-28hj-76wf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (bn.js 5.2.3, 4.12.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm bn.js

    Affected
    < 4.12.3>= 5.0.0, < 5.2.3
    Fixed in
    4.12.3, 5.2.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P · score source
EPSS
  • CVE-2026-2739: 0.53% estimated exploitation activity in the next 30 days; percentile 44.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

This affects versions of the package bn.js before 4.12.3 and 5.2.3. Calling maskn(0) on any BN instance corrupts the internal state, causing toString(), divmod(), and other methods to enter an infinite loop, hanging the process indefinitely.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-378v-28hj-76wf

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-378v-28hj-76wf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-2739

Advisory: bn.js affected by an infinite loop
IDs: CVE-2026-2739, GHSA-378v-28hj-76wf
Record: https://patchnext.com/advisories/cve-2026-2739 (revision 3, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: bn.js 5.2.3, 4.12.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm bn.js: affected < 4.12.3; >= 5.0.0, < 5.2.3; fixed in 4.12.3, 5.2.3

## Suggested inspection (read-only)
- `npm ls bn.js --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on bn.js.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-378v-28hj-76wf (OSV record GHSA-378v-28hj-76wf lists affected ranges: npm bn.js >=0 =5.0.0 <5.2.3 (fixed))
- Verified: https://github.com/advisories/GHSA-378v-28hj-76wf (GitHub-reviewed advisory GHSA-378v-28hj-76wf lists affected ranges: npm bn.js >=0 =5.0.0 <5.2.3)

Commands are suggestions: review each one before running it.

Loading voting…