Apache Cassandra has sensitive Information Leak in cqlsh
CVE-2026-27315GHSA-fh34-c629-p8xj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.cassandra:cassandra-all 4.0.20), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.cassandra:cassandra-all
- Affected
- >= 4.0, < 4.0.20
- Fixed in
- 4.0.20
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fh34-c629-p8xj lists affected ranges: Maven org.apache.cassandra:cassandra-all >=4.0 <4.0.20
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-27315: 0.16% estimated exploitation activity in the next 30 days; percentile 5.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Sensitive Information Leak in cqlsh in Apache Cassandra 4.0 allows access to sensitive information, like passwords, from previously executed cqlsh command via ~/.cassandra/cqlshhistory local file access. Users are recommended to upgrade to version 4.0.20, which fixes this issue. -- Description: Cassandra's command-line tool, cqlsh, provides a command history feature that allows users to recall previously executed commands using the up/down arrow keys. These history records are saved in the ~/.cassandra/cqlshhistory file in the user's home directory. However, cqlsh does not redact sensitive information when saving command history. This means that if a user executes operations involving passwords (such as logging in or creating users) within cqlsh, these passwords are permanently stored in cleartext in the history file on the disk.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fh34-c629-p8xj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-27315 Advisory: Apache Cassandra has sensitive Information Leak in cqlsh IDs: CVE-2026-27315, GHSA-fh34-c629-p8xj Record: https://patchnext.com/advisories/cve-2026-27315 (revision 1, source checked 26 Oct 2026, 16:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.cassandra:cassandra-all 4.0.20. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.cassandra:cassandra-all: affected >= 4.0, < 4.0.20; fixed in 4.0.20 ## Suggested inspection (read-only) - Maven org.apache.cassandra:cassandra-all: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.cassandra:cassandra-all. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fh34-c629-p8xj (GitHub-reviewed advisory GHSA-fh34-c629-p8xj lists affected ranges: Maven org.apache.cassandra:cassandra-all >=4.0 <4.0.20) Commands are suggestions: review each one before running it.
Loading voting…