Apache Cassandra is vulnerable to privilege escalation in an mTLS environment using MutualTlsAuthenticator
CVE-2026-27314GHSA-qxpc-96fq-wwmg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.cassandra:cassandra-all 5.0.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.cassandra:cassandra-all
- Affected
- >= 5.0-alpha1, < 5.0.7
- Fixed in
- 5.0.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qxpc-96fq-wwmg lists affected ranges: Maven org.apache.cassandra:cassandra-all >=5.0-alpha1 <5.0.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-27314: 0.26% estimated exploitation activity in the next 30 days; percentile 18.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Privilege escalation in Apache Cassandra 5.0 on an mTLS environment using MutualTlsAuthenticator allows a user with only CREATE permission to associate their own certificate identity with an arbitrary role, including a superuser role, and authenticate as that role via ADD IDENTITY. Users are recommended to upgrade to version 5.0.7+, which fixes this issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qxpc-96fq-wwmg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-27314 Advisory: Apache Cassandra is vulnerable to privilege escalation in an mTLS environment using MutualTlsAuthenticator IDs: CVE-2026-27314, GHSA-qxpc-96fq-wwmg Record: https://patchnext.com/advisories/cve-2026-27314 (revision 1, source checked 26 Oct 2026, 16:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.cassandra:cassandra-all 5.0.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.cassandra:cassandra-all: affected >= 5.0-alpha1, < 5.0.7; fixed in 5.0.7 ## Suggested inspection (read-only) - Maven org.apache.cassandra:cassandra-all: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.cassandra:cassandra-all. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qxpc-96fq-wwmg (GitHub-reviewed advisory GHSA-qxpc-96fq-wwmg lists affected ranges: Maven org.apache.cassandra:cassandra-all >=5.0-alpha1 <5.0.7) Commands are suggestions: review each one before running it.
Loading voting…