LibreNMS: Cross-Site Scripting in ShowConfigController
CVE-2026-2728GHSA-5gm9-622f-qcg5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (librenms/librenms 26.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist librenms/librenms
- Affected
- >= 25.12.0, < 26.3.0
- Fixed in
- 26.3.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5gm9-622f-qcg5 lists affected ranges: Packagist librenms/librenms >=25.12.0 <26.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.5 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:N
- EPSS
- CVE-2026-2728: 0.22% estimated exploitation activity in the next 30 days; percentile 13.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A Stored Cross-Site Scripting (XSS) vulnerability exists in the ShowConfig page of devices affected by the RANCID Integration settings. The application fails to properly sanitise the rancidrepourl configuration value. When a user navigates to a device's configuration page, this unsanitised value is rendered directly within an HTML anchor (<a>) tag. This allows an authenticated user with permission to modify external settings to inject malicious JavaScript that will execute in the browser of any user viewing the affected device pages. Details The vulnerability is located in the external settings configuration block, specifically at the settings/external/rancid endpoint. When a valid rancidconfigs is set, the application renders the corresponding rancidrepourl as a clickable link labeled "Git Repository" on the /device/{id}/showconfig UI. Because the rancidrepourl input is neither validated upon saving nor contextually encoded upon rendering, an attacker can break out of…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5gm9-622f-qcg5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-2728 Advisory: LibreNMS: Cross-Site Scripting in ShowConfigController IDs: CVE-2026-2728, GHSA-5gm9-622f-qcg5 Record: https://patchnext.com/advisories/cve-2026-2728 (revision 1, source checked 26 Oct 2026, 14:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: librenms/librenms 26.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist librenms/librenms: affected >= 25.12.0, < 26.3.0; fixed in 26.3.0 ## Suggested inspection (read-only) - Packagist librenms/librenms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on librenms/librenms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5gm9-622f-qcg5 (GitHub-reviewed advisory GHSA-5gm9-622f-qcg5 lists affected ranges: Packagist librenms/librenms >=25.12.0 <26.3.0) Commands are suggestions: review each one before running it.
Loading voting…